This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 132836 - nautilus displays corrupted thumbnails
nautilus displays corrupted thumbnails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 133213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 12:46 EDT by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 17:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2004-09-17 12:46:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
When I browse a folder with some images, the thumbails are partly
corrupted. What happens is that the right side of all thumbnails has
white noise. Funny enough when inspecting the files in ~/.thumbnails
with an image viewer, all of them seem ok.


How reproducible:
Always


Steps to Reproduce:
1.go to a folder containing imagens
2.look at the thumbails
    

Actual Results:
All of them are corrupted on the right side.


Expected Results:
They shouldn't be corrupted (as the thumbnail files themselves are fine).


Additional info:
I only noticed this today, so this must have been triggered by some
recent update, like gdk-pixbuf-0.22.0-11.3.5 or gtk2-2.4.7-2.5.
Comment 1 Scott Phipps 2004-09-17 13:12:56 EDT
I also have this problem after the update.  It souds like the problem
might relate to bug 130183.
Comment 2 Alar Suija 2004-09-18 12:18:16 EDT
Yes, i have this problem too, after using 'yum update'

(from yum.log)
09/18/04 09:46:18 Updated: gdk-pixbuf 1:0.22.0-11.3.5.i386
09/18/04 09:46:18 Updated: gtk2 2.4.7-2.5.i386

Comment 3 Aapo Aarnio 2004-09-18 16:34:39 EDT
 I have the same problem.  When I doubleclick a jpeg image, one with
the image preview lacking 25% at the right side (white or white
noise), i get: "The Image view encountered an error while starting up.
The location cannot be displayed with this viewer." If I select view
as image collection: 
"The Image Collection view encountered an error while starting up. The
location cannot be displayed with this viewer."
 If I select open with eye of the gnome (or any other viewer), it
opens normally. The problem appeared after nautilus got stuck while
browsing image-folders and required a force quit. This was maybe 10
hours after the updates.
 
Comment 4 Aapo Aarnio 2004-09-18 17:15:09 EDT
 Sorry I was writing about jpegs and just checked, it's all images,
not just jpegs. 
  I forgot to mention that I was browsing image folders heavily for some 
time before this appeared. 
 
Comment 5 Alexander Larsson 2004-09-21 10:13:17 EDT
Yes. This was a gdk-pixbuf bug in some gtk2 release.
Comment 6 Matthias Clasen 2004-09-21 11:30:10 EDT
gtk2-2.4.7-2.6 which is now in testing should fix this.
Comment 7 Thorsten Leemhuis 2004-09-22 01:45:20 EDT
Matthias, just FYI, seeing Bug 128214 with clock applet since
gtk2-2.4.7-2.5 and also with gtk2-2.4.7-2.6 (panel height 16 pixel) --
worked fine before update.
Comment 8 Matthias Clasen 2004-09-22 01:50:19 EDT
Thorsten, I would be more interested to hear if you still see *this*
bug with 2.4.7-2.6
Comment 9 Thorsten Leemhuis 2004-09-22 02:02:26 EDT
Matthias, sorry, when I saw 
"The gtk2-2.4.7-2.6 package which is available for testing now should
fix that. Please test and report problems in [HERE]"
on fedora-test-list I thought you mean *all* problems with the update.

But a quick look with nautilus in an dir with images did not show the
problem reported in this bug.
Comment 10 Alexander Larsson 2004-09-22 12:08:45 EDT
*** Bug 133213 has been marked as a duplicate of this bug. ***
Comment 11 Carlos Rodrigues 2004-09-23 17:43:15 EDT
It doesn't happen anymore with the latest gtk2 update.

Note You need to log in before you can comment on or make changes to this bug.