Bug 1328836 - glusterfs-libs postun ldconfig: relative path `1' used to build cache
Summary: glusterfs-libs postun ldconfig: relative path `1' used to build cache
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.7.11
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1330583 1331844
TreeView+ depends on / blocked
 
Reported: 2016-04-20 11:53 UTC by rstory
Modified: 2016-06-28 12:14 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1330583 1339610 (view as bug list)
Environment:
Last Closed: 2016-06-28 12:14:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description rstory 2016-04-20 11:53:05 UTC
Description of problem:

A recent run of /etc/cron.daily/0yum.cron got this output:

/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(glusterfs-libs-3.7.10-1.el6.x86_64) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package glusterfs-libs


Looking back, I saw this for glusterfs-libs-3.7.9-1.el6.x86_64 as well.


Version-Release number of selected component (if applicable):
glusterfs-libs-3.7.11-1.el6.x86_64

How reproducible:
seems to happen on every update

Steps to Reproduce:
1. install older rpm
2. yum update
3.

Actual results:
error message

Expected results:
no error message

Additional info:
Seems to be quite a few rpms with this same issue in bugzilla, A quick search might help you find an easy solution.

Comment 1 Kaleb KEITHLEY 2016-04-26 12:44:34 UTC
This was fixed, in Fedora at least, in 3.7.9.

It seems there's something different about RHEL or RHEL6.

Comment 2 Vijay Bellur 2016-04-26 14:45:43 UTC
REVIEW: http://review.gluster.org/14082 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Vijay Bellur 2016-04-26 22:57:12 UTC
REVIEW: http://review.gluster.org/14082 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Vijay Bellur 2016-04-29 10:09:41 UTC
COMMIT: http://review.gluster.org/14082 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 6659ff9b81ba0f47e7dd85f947cb8ed5bb41ac26
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 26 10:33:54 2016 -0400

    packaging: %postun libs ldconfig: relative path `1' used to build cache
    
    %postun libs isn't 'closed' by the following %postun server on RHEL6
    due to the %ifdef...%endif
    
    But -server has /usr/lib*/libgfdb.so.x, so we should be running
    /sbin/ldconfig! Which conveniently fixes the closing issue.
    
    See:
    > Change-Id: Icc365eefc5453c40e02b59288a4e8023b82baa7b
    > BUG: 1330583
    > http://review.gluster.org/14081
    
    Change-Id: I7c2daf1408aaee6340e6983cfaba207c5d13f5a1
    BUG: 1328836
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14082
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 5 Vijay Bellur 2016-05-13 14:49:17 UTC
REVIEW: http://review.gluster.org/14335 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 6 Vijay Bellur 2016-05-13 14:50:23 UTC
REVIEW: http://review.gluster.org/14335 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#2) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 7 Milind Changire 2016-05-13 15:08:15 UTC
Uploading another patch.
Moving to POST to get accepted by smoke build.

Comment 8 Vijay Bellur 2016-05-13 15:08:57 UTC
REVIEW: http://review.gluster.org/14335 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#3) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 9 Vijay Bellur 2016-05-26 14:10:04 UTC
COMMIT: http://review.gluster.org/14335 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 2db5ac501be76bf20f459f0d1440ea6b4ee2d04c
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri May 13 01:12:10 2016 +0530

    packaging: %postun libs ldconfig: relative path `1' used to build cache
    
    Remove %post{un} {libs|api} -p /sbin/ldconfig optimization and
    move /sbin/ldconfig on a separate line.
    
    Upstream patch:
    http://review.gluster.org/14312
    
    Change-Id: I8a4c3879afcb7cea08d4b303a2524432d2ffec06
    BUG: 1328836
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14312
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    (cherry picked from commit 84ec13831a4f02cfa8295c9f23b75bf39dc9be30)
    Reviewed-on: http://review.gluster.org/14335
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 10 Kaushal 2016-06-28 12:14:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.