Bug 1331844 - glusterfs-libs postun ldconfig: relative path `1' used to build cache
Summary: glusterfs-libs postun ldconfig: relative path `1' used to build cache
Keywords:
Status: CLOSED DUPLICATE of bug 1328194
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution
Version: rhgs-3.1
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Sreenath G
QA Contact: Kaleb KEITHLEY
URL:
Whiteboard:
Depends On: 1328836 1330583
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-29 19:17 UTC by Kaleb KEITHLEY
Modified: 2016-05-03 09:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1330583
Environment:
Last Closed: 2016-05-02 18:10:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2016-04-29 19:17:56 UTC
+++ This bug was initially created as a clone of Bug #1330583 +++

+++ This bug was initially created as a clone of Bug #1328836 +++

Description of problem:

A recent run of /etc/cron.daily/0yum.cron got this output:

/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(glusterfs-libs-3.7.10-1.el6.x86_64) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package glusterfs-libs


Looking back, I saw this for glusterfs-libs-3.7.9-1.el6.x86_64 as well.


Version-Release number of selected component (if applicable):
glusterfs-libs-3.7.11-1.el6.x86_64

How reproducible:
seems to happen on every update

Steps to Reproduce:
1. install older rpm
2. yum update
3.

Actual results:
error message

Expected results:
no error message

Additional info:
Seems to be quite a few rpms with this same issue in bugzilla, A quick search might help you find an easy solution.

--- Additional comment from Kaleb KEITHLEY on 2016-04-26 08:44:34 EDT ---

This was fixed, in Fedora at least, in 3.7.9.

It seems there's something different about RHEL or RHEL6.

--- Additional comment from Vijay Bellur on 2016-04-26 10:28:37 EDT ---

REVIEW: http://review.gluster.org/14081 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-26 18:33:40 EDT ---

REVIEW: http://review.gluster.org/14081 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-27 10:30:42 EDT ---

COMMIT: http://review.gluster.org/14081 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 49796290c9772ce49e5a1666cc2f3cc875e59e49
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 26 10:10:05 2016 -0400

    packaging: %postun libs ldconfig: relative path `1' used to build cache
    
    %postun libs isn't 'closed' by the following %postun server on RHEL6
    due to the %ifdef...%endif
    
    But -server has /usr/lib*/libgfdb.so.x, so we should be running
    /sbin/ldconfig! Which conveniently fixes the closing issue.
    
    Change-Id: Icc365eefc5453c40e02b59288a4e8023b82baa7b
    BUG: 1330583
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14081
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 2 Kaleb KEITHLEY 2016-05-02 18:10:37 UTC

*** This bug has been marked as a duplicate of bug 1328194 ***


Note You need to log in before you can comment on or make changes to this bug.