Bug 1330583 - glusterfs-libs postun ldconfig: relative path `1' used to build cache
Summary: glusterfs-libs postun ldconfig: relative path `1' used to build cache
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: mainline
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
Depends On: 1328836
Blocks: 1331844
TreeView+ depends on / blocked
 
Reported: 2016-04-26 14:03 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 14:04 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1328836
: 1331844 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:04:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2016-04-26 14:03:05 UTC
+++ This bug was initially created as a clone of Bug #1328836 +++

Description of problem:

A recent run of /etc/cron.daily/0yum.cron got this output:

/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(glusterfs-libs-3.7.10-1.el6.x86_64) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package glusterfs-libs


Looking back, I saw this for glusterfs-libs-3.7.9-1.el6.x86_64 as well.


Version-Release number of selected component (if applicable):
glusterfs-libs-3.7.11-1.el6.x86_64

How reproducible:
seems to happen on every update

Steps to Reproduce:
1. install older rpm
2. yum update
3.

Actual results:
error message

Expected results:
no error message

Additional info:
Seems to be quite a few rpms with this same issue in bugzilla, A quick search might help you find an easy solution.

--- Additional comment from Kaleb KEITHLEY on 2016-04-26 08:44:34 EDT ---

This was fixed, in Fedora at least, in 3.7.9.

It seems there's something different about RHEL or RHEL6.

Comment 1 Vijay Bellur 2016-04-26 14:28:37 UTC
REVIEW: http://review.gluster.org/14081 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Vijay Bellur 2016-04-26 22:33:40 UTC
REVIEW: http://review.gluster.org/14081 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Vijay Bellur 2016-04-27 14:30:42 UTC
COMMIT: http://review.gluster.org/14081 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 49796290c9772ce49e5a1666cc2f3cc875e59e49
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 26 10:10:05 2016 -0400

    packaging: %postun libs ldconfig: relative path `1' used to build cache
    
    %postun libs isn't 'closed' by the following %postun server on RHEL6
    due to the %ifdef...%endif
    
    But -server has /usr/lib*/libgfdb.so.x, so we should be running
    /sbin/ldconfig! Which conveniently fixes the closing issue.
    
    Change-Id: Icc365eefc5453c40e02b59288a4e8023b82baa7b
    BUG: 1330583
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14081
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Vijay Bellur 2016-05-12 19:49:38 UTC
REVIEW: http://review.gluster.org/14312 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 5 Milind Changire 2016-05-12 20:14:15 UTC
Kaleb's patch did not completely fix the issue.
Removing %post{un} {api|libs} -p /sbin/ldconfig optmization.
Moving /sbin/ldconfig invokation to a line of its own and removing "-p"

Comment 6 Milind Changire 2016-05-12 20:16:38 UTC
mistakenly moved the wrong BZ to ASSIGNED.
Please ignore comment #5.
moving to MODIFIED again.

Comment 7 Vijay Bellur 2016-05-12 20:20:13 UTC
REVIEW: http://review.gluster.org/14312 (packaging: %postun libs ldconfig: relative path `1' used to build cache) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

Comment 8 Vijay Bellur 2016-05-13 07:54:44 UTC
COMMIT: http://review.gluster.org/14312 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 84ec13831a4f02cfa8295c9f23b75bf39dc9be30
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri May 13 01:12:10 2016 +0530

    packaging: %postun libs ldconfig: relative path `1' used to build cache
    
    Remove %post{un} {libs|api} -p /sbin/ldconfig optimization and
    move  /sbin/ldconfig on a separate line.
    
    Change-Id: I8a4c3879afcb7cea08d4b303a2524432d2ffec06
    BUG: 1330583
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14312
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 9 Niels de Vos 2016-06-16 14:04:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.