Bug 13291 - kernel-headers-2.2.16-3 update breaks /usr/include/linux
Summary: kernel-headers-2.2.16-3 update breaks /usr/include/linux
Status: CLOSED DUPLICATE of bug 13272
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 13517 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-30 20:10 UTC by roger.bivand
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 19:18:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description roger.bivand 2000-06-30 20:10:09 UTC
rpm -Uvh kernel-headers-2.2.16-3.i386.rpm removed my /usr/include/linux
and /usr/include/asm symbolic links, meaning that gcc couldn't find
headers (both egcs aka gcc-2.91, the 6.* standard, and gcc-2.95.2 from
Mandrake)

fix: rpm -ivh --force kernel-headers-2.2.14-12.i386.rpm

Shouldn't updating a package set up the links? /usr/include/linux & asm
were simply not there at all after upgrading.

Comment 1 roger.bivand 2000-07-03 06:59:06 UTC
Typo in summary: /usr/linux/include should be /usr/include/linux

Both my machines also run libsafe, but are otherwise standard RH6.2. No libsafe
messages in /var/log/secure (had there been buffer overrun events in any of the
actions undertaken during rpm update, libsafe would have aborted the component
processes).

Although on kernel upgrade I had gcc-2.95.2 from Mandrake, the problem was the
same after removing these and installing egcs gcc, so it seems to point at
something missing in the upgrade process for 2.2.16-3 headers - the symlinks for
earlier kernel headers get removed, but no new ones put in place.

Comment 2 roger.bivand 2000-07-10 14:51:15 UTC
Looks as though #13517 is the same (even if mine is i386 and the other sparc).

Comment 3 roger.bivand 2000-07-12 07:47:27 UTC
This has been reported as #13517, #13711 - see comments there too

Comment 4 Alan Cox 2000-08-22 19:17:59 UTC
*** Bug 13517 has been marked as a duplicate of this bug. ***

Comment 5 Alan Cox 2000-09-16 22:12:58 UTC

*** This bug has been marked as a duplicate of 13272 ***


Note You need to log in before you can comment on or make changes to this bug.