Bug 1330253 - Autodetection of of nodes during 2nd deployment with same undercloud allows registration of fusor and/or director
Summary: Autodetection of of nodes during 2nd deployment with same undercloud allows r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: Landon LaSmith
URL:
Whiteboard:
Depends On:
Blocks: qci-sprint-17
TreeView+ depends on / blocked
 
Reported: 2016-04-25 18:04 UTC by Landon LaSmith
Modified: 2016-09-13 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:28:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of auto-detected fusor/director (25.95 KB, image/png)
2016-04-25 18:04 UTC, Landon LaSmith
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1328995 None None None Never
Red Hat Bugzilla 1358567 None None None Never
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Internal Links: 1328995 1358567

Description Landon LaSmith 2016-04-25 18:04:04 UTC
Created attachment 1150584 [details]
Screenshot of auto-detected fusor/director

Description of problem: When creating a 2nd deployment that uses the same undercloud as a previous deployment, autodetection allows registration of the fusor and/or director

Version-Release number of selected component (if applicable): TP3 RC4


How reproducible: 100%


Steps to Reproduce:
1. Create a deployment, register osp nodes using pxe_ssh and kick off deployment
2. Create a second deployment
3. Register the same undercloud used in previous deployment
4. Use auto detection to query the same pxe_ssh server as above

Actual results: The fusor and director machines used in the current deployment are options for node registration.  Any OSP nodes already registered are missing (as expected)

Expected results: Fusor and director VMs should be absent for the auto-detection list

Additional info:

Comment 1 John Matthews 2016-06-20 18:29:46 UTC
Please re-test, we intend to only support one deployment for each undercloud.

Comment 3 Landon LaSmith 2016-07-21 15:50:50 UTC
Per comment #1, I was able to delete and reuse the undercloud for a 2nd deployment using the WebUI.  The previous nodes used for the overcloud were already registered and that registration was reflected in the WebUI.

Comment 4 Landon LaSmith 2016-07-21 15:57:08 UTC
I was still able to select the fusor and undercloud VMs during autodetection, I will mark this a VERIFIED. I submitted an RFE bug to disable fusor/undercloud nodes from selection during any node registration

Comment 9 errata-xmlrpc 2016-09-13 16:28:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.