Bug 1333912 - client ID should logged when SSL connection fails
Summary: client ID should logged when SSL connection fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra Bhat
QA Contact:
URL:
Whiteboard:
: 1333913 1333914 (view as bug list)
Depends On: 1333885 1380275 1383879 1383882
Blocks: 1351878 1351933 1353429
TreeView+ depends on / blocked
 
Reported: 2016-05-06 16:11 UTC by Raghavendra Bhat
Modified: 2017-03-27 18:25 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1333885
: 1351878 1351933 1353429 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:25:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Bhat 2016-05-06 16:11:15 UTC
+++ This bug was initially created as a clone of Bug #1333885 +++

Description of problem:

when a client tries to connect using SSl, and the connection fails, the client identifier (either IP address or the hostname) should be logged to help identify which client was attempting the connect.

[2016-04-04 13:06:57.982869] E [socket.c:352:ssl_setup_connection] 0-socket.management: SSL connect error
[2016-04-04 13:06:57.983084] E [socket.c:206:ssl_dump_error_stack] 0-socket.management:   error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
[2016-04-04 13:06:57.983276] E [socket.c:2388:socket_poller] 0-socket.management: server setup failed
[2016-04-04 13:07:00.987987] E [socket.c:352:ssl_setup_connection] 0-socket.management: SSL connect error
[2016-04-04 13:07:00.988203] E [socket.c:206:ssl_dump_error_stack] 0-socket.management:   error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

In the above logs ssl_setup_connection does not log the client identifier.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Raghavendra Bhat 2016-05-06 16:13:51 UTC
*** Bug 1333914 has been marked as a duplicate of this bug. ***

Comment 2 Raghavendra Bhat 2016-05-06 16:14:17 UTC
*** Bug 1333913 has been marked as a duplicate of this bug. ***

Comment 3 Vijay Bellur 2016-05-06 16:16:03 UTC
REVIEW: http://review.gluster.org/14242 (socket: log the client identifier in ssl connect) posted (#2) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 4 Vijay Bellur 2016-06-29 17:04:08 UTC
REVIEW: http://review.gluster.org/14242 (socket: log the client identifier in ssl connect) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 5 Vijay Bellur 2016-06-30 22:24:23 UTC
COMMIT: http://review.gluster.org/14242 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit d308fb5e152d8c908bf4f5da81f553fbe3d0400a
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Fri May 6 10:03:53 2016 -0400

    socket: log the client identifier in ssl connect
    
    Change-Id: I4b463ecafb66de16cbe7ed23fae800bb1204f829
    BUG: 1333912
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/14242
    Tested-by: Vijay Bellur <vbellur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 6 Mohit Agrawal 2016-11-08 11:27:52 UTC
Hi,

  The message does not exist in 3.1.3 because it was introduced from the patch(http://review.gluster.org/#/c/14242/) in bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1333912).We can't remove these message because these messages are intended by customer to show the ssl connection status in logs.

Regards
Mohit Agrawal

Comment 8 Mohit Agrawal 2016-11-09 05:38:40 UTC
Hi,

  Please ignore comment#6,i have posted the comment by mistake in this bugzilla.
  The comment was for bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1389678),the fix 
  was introduced from this bugzilla.

Regards
Mohit Agrawal

Comment 9 Shyamsundar 2017-03-27 18:25:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.