Bug 1334470 - [RFE] console-agent should emit events for Block device related changes.
Summary: [RFE] console-agent should emit events for Block device related changes.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: agent
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Darshan
QA Contact: Martin Kudlej
URL:
Whiteboard:
: 1304226 (view as bug list)
Depends On: 1304226
Blocks: 1291304 Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-09 17:15 UTC by Christina Meno
Modified: 2016-08-23 19:50 UTC (History)
9 users (show)

Fixed In Version: rhscon-ceph-0.0.40-1.el7scon.x86_64.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of: 1304226
Environment:
Last Closed: 2016-08-23 19:50:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
status after creating rbds from UI which doesn't change after chnages from CLI (17.04 KB, image/png)
2016-08-03 15:30 UTC, Martin Kudlej
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 277331 None None None 2016-06-23 10:02:51 UTC
Gerrithub.io 279216 None None None 2016-06-23 10:02:29 UTC
Gerrithub.io 286311 None None None 2016-08-04 12:01:10 UTC
Red Hat Bugzilla 1315800 None None None Never
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1315800

Comment 1 Christina Meno 2016-05-09 17:17:02 UTC
*** Bug 1304226 has been marked as a duplicate of this bug. ***

Comment 5 Martin Kudlej 2016-08-03 15:26:57 UTC
Tested with
server:
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.39-1.el7scon.x86_64
rhscon-core-0.0.39-1.el7scon.x86_64
rhscon-core-selinux-0.0.39-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
monitor with calamari:
calamari-server-1.4.8-1.el7cp.x86_64
ceph-base-10.2.2-33.el7cp.x86_64
ceph-common-10.2.2-33.el7cp.x86_64
ceph-mon-10.2.2-33.el7cp.x86_64
ceph-selinux-10.2.2-33.el7cp.x86_64
libcephfs1-10.2.2-33.el7cp.x86_64
python-cephfs-10.2.2-33.el7cp.x86_64
rhscon-agent-0.0.16-1.el7scon.noarch
rhscon-core-selinux-0.0.39-1.el7scon.noarch

and it does not work for RBDs.

Reproducer:
1. create rbd1 and rbd2 from UI
2. from CLI remove rbd1, resize rbd2 and add rb3
3. watch list of rbds

Comment 6 Martin Kudlej 2016-08-03 15:30:38 UTC
Created attachment 1187114 [details]
status after creating rbds from UI which doesn't change after chnages from CLI

Comment 7 Martin Kudlej 2016-08-03 15:50:04 UTC
Created attachment 1187116 [details]
logs from monitor node with calamari and server

Comment 8 Martin Kudlej 2016-08-03 15:57:04 UTC
$ rbd -c /etc/ceph/cl1.conf --pool=pool1 list
rbd1
rbd3

$ rbd -c /etc/ceph/cl1.conf --pool=pool1 info rbd1
rbd image 'rbd1':
	size 2048 MB in 512 objects
	order 22 (4096 kB objects)
	block_name_prefix: rbd_data.1a1b2ae8944a
	format: 2
	features: layering, exclusive-lock, object-map, fast-diff, deep-flatten
	flags: 
$ rbd -c /etc/ceph/cl1.conf --pool=pool1 info rbd3
rbd image 'rbd3':
	size 3072 MB in 768 objects
	order 22 (4096 kB objects)
	block_name_prefix: rbd_data.41c42ae8944a
	format: 2
	features: layering, exclusive-lock, object-map, fast-diff, deep-flatten
	flags:

Comment 9 Martin Kudlej 2016-08-08 13:37:55 UTC
Tested with
ceph-ansible-1.0.5-32.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.40-1.el7scon.x86_64
rhscon-core-0.0.41-1.el7scon.x86_64
rhscon-core-selinux-0.0.41-1.el7scon.noarch
rhscon-ui-0.0.52-1.el7scon.noarch
and it works.

Comment 11 errata-xmlrpc 2016-08-23 19:50:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.