Bug 1304226 - [RFE] Calamari should emit events for Block device related changes. [NEEDINFO]
[RFE] Calamari should emit events for Block device related changes.
Status: CLOSED DUPLICATE of bug 1334470
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Gregory Meno
ceph-qe-bugs
:
Depends On:
Blocks: 1291304 1334470
  Show dependency treegraph
 
Reported: 2016-02-03 00:36 EST by Darshan
Modified: 2016-05-09 13:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1334470 (view as bug list)
Environment:
Last Closed: 2016-05-09 13:17:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gmeno: needinfo? (nthomas)


Attachments (Terms of Use)

  None (edit)
Description Darshan 2016-02-03 00:36:56 EST
Description of problem:
calamari should emit events when ever a block device is created / resized or deleted, with all relevant information

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Gregory Meno 2016-05-04 11:47:28 EDT
Nishanth, see concerns here https://github.com/ceph/calamari/pull/436
I suggest that there are two paths forward.

1. I try to add threading to calamari-server and move this polling code up there

2. We migrate this polling eventing/code to be a task that the salt-minion runs 

1 carries more risk to the schedule and 2 is more likely to work without concerns. This is because salt-minion jobs are separate short-live processes. If the rdb ls gets stuck there it is isolated from both calamari and storage console. 

option one carries the risk that it is not a pattern that exists in calamari-server todate and would require me to spend more time there instead of working on https://bugzilla.redhat.com/show_bug.cgi?id=1324671
Comment 4 Gregory Meno 2016-05-09 13:17:02 EDT

*** This bug has been marked as a duplicate of bug 1334470 ***

Note You need to log in before you can comment on or make changes to this bug.