Bug 1335682 - [RFE] Install Ceph RBD Mirroring daemon [NEEDINFO]
Summary: [RFE] Install Ceph RBD Mirroring daemon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
Don Domingo
URL:
Whiteboard:
: 1262100 (view as bug list)
Depends On: 1283413 1408476
Blocks: 1291943 1317347 1387433
TreeView+ depends on / blocked
 
Reported: 2016-05-12 22:01 UTC by Jason Dillaman
Modified: 2019-02-26 22:31 UTC (History)
18 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170127041112.ce54697.el7ost.1.noarch
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:30:09 UTC
jefbrown: needinfo? (kschinck)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 401416 None None None 2017-01-17 10:08:40 UTC
OpenStack gerrit 407038 None None None 2017-01-17 10:08:58 UTC
OpenStack gerrit 407039 None None None 2017-01-17 10:09:18 UTC
OpenStack gerrit 414346 None None None 2017-01-17 10:08:20 UTC

Description Jason Dillaman 2016-05-12 22:01:31 UTC
Description of problem:
Cinder Volume Replication via RBD Mirroring requires the Ceph 'rbd-mirror' package to be installed and configured on at least one host per peer cluster. The host will require the Ceph configuration file for both the local Ceph cluster and the remote peer cluster as the daemon needs to connect to both clusters concurrently.

Comment 2 Sean Cohen 2016-05-18 12:28:33 UTC
*** Bug 1262100 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Brown 2016-07-13 19:24:44 UTC
Hi Keith,

Can we leverage the work your doing to support this in OSP10?

Thanks,

Jeff

Comment 4 seb 2016-07-19 13:15:28 UTC
It's actually easy, we just need to have the "rbd-mirror" package as part of the image that will have RHCS 2.0 installed. It's 'just' one extra package to install.

Comment 5 seb 2016-09-02 15:08:39 UTC
Yogev, can you give us the status of this?
Thanks!

Comment 13 Yogev Rabl 2017-03-02 16:10:59 UTC
Verified. 
The RBD mirror service is available, running, and part of the Pacemaker configuration

Comment 14 errata-xmlrpc 2017-05-17 19:30:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.