Bug 133658 - (firefox-lc-paper) Firefox does not adhere LC_PAPER locale category
Firefox does not adhere LC_PAPER locale category
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Horak
:
: 154545 166105 186735 ff-print-letter (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 16:41 EDT by Kyrre Ness Sjøbæk
Modified: 2013-04-12 01:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 09:11:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 144625 None None None Never
Mozilla Foundation 147419 None None None Never

  None (edit)
Description Kyrre Ness Sjøbæk 2004-09-25 16:41:57 EDT
Description of problem:
In the "print setup" dialog box, i have noticed that it states that
"Letter" is the default. Only problem is that i am i Norway, where
letter is only encountered in printer driver setup...

Version-Release number of selected component (if applicable):
firefox-0.10.0-1.0PR1.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Great and usefull work getting the printer list to work! Will this
find it way back to mozilla/epiphany?
Comment 1 Warren Togami 2005-05-16 05:24:34 EDT
If this is still an issue, please file it upstream.  This is something upstream
Mozilla Project should fix.

Is this still an issue in FC4?
Comment 2 Kyrre Ness Sjøbæk 2005-05-16 07:27:45 EDT
Yes. I have a printer which in cups (remote machine) is setup to use "A4", but
when i click on properties for the printer in firefox'es printing dialog, it is
convinced it should produce an Letter postscript...

This does sometimes make advanced printers "hang" - as they do care about which
paper they have, and not have, and so sits there demanding that somebody please
put letter i tray X (or reset it...). Or even worse - they simply fail silently
- the "busy" ligth turns on, turns off (so the data is recived) - and they do
nothing. Very, very difficult to debug.

This is firefox-1.0.4-2 btw.
Comment 3 Warren Togami 2005-05-16 15:43:01 EDT
Please make sure this is filed upstream too.  Give the upstream bug URL here.
Comment 4 Kyrre Ness Sjøbæk 2005-05-17 11:52:56 EDT
I really don't want to have yet another bugzilla account to take care of. But it
was already reported:
https://bugzilla.mozilla.org/show_bug.cgi?id=144625
Comment 5 Warren Togami 2005-10-01 00:21:16 EDT
*** Bug 166105 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2005-10-01 00:21:23 EDT
*** Bug 154545 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Wright 2005-10-09 05:35:54 EDT
This is masked at many sites because HP printers have the options Auto Overide
A4=YES*  In their settings on the front panel of the printer.

In this instance the printer doesn't care if it gets A4 or Letter it just auto
scales and prints regardless.   The feature however available to many masks this
problem.
Comment 8 Kyrre Ness Sjøbæk 2005-10-09 07:27:22 EDT
But if this is not the case (or, in the case of old HP laser printers), it will
just refuse to print. Take a look at the two duplicates (and yes, i did report
this bug twice - forgot i reported it once and did it again...)

Sometimes the busy ligth just glows for five secounds, and then nothing happens
- not even an error message. Makes this really really hard to debug...
Comment 9 Matthew Wright 2005-10-09 17:25:57 EDT
I agree that it needs fixing,  problem is that Fedora people probably
predominately have a US centric view of the world so this stuff doesn't get much
attention.  -- I too have the problem with older HP printers  ir 4MV Plus and 4Plus.
Comment 10 Warren Togami 2005-10-09 23:07:54 EDT
> Fedora people probably predominately have a US centric view of the world

This might be true to an extent, but keep in mind that the only way this will
get into Fedora is if someone implements it upstream at mozilla.org first.
Comment 12 Kyrre Ness Sjøbæk 2006-02-14 15:31:03 EST
Great that this was made FC6Target, but it would be great to have it before
then. Firefox is the standard webbrowser in both Fedora and RHEL (as well as a
lot of other distros), and many people depend on it working. I would not be
suprised it is the number one used program on a lot of computers. Having
problems with printing (even if print rendering got much better with 1.5) -
especially problems such as "nothing comes out of the printer, silently" - is
Very Bad. It also causes problems with placement of headers etc.
Comment 13 Warren Togami 2006-02-14 17:34:00 EST
It has been stated clearly that this is an issue that must be first fixed in
upstream mozilla.org.  Fedora will follow upstream, and Fedora tries to stay
away from diverging away from upstream.
Comment 14 Matthew Wright 2006-03-23 15:41:46 EST
(In reply to comment #13)
> It has been stated clearly that this is an issue that must be first fixed in
> upstream mozilla.org.  Fedora will follow upstream, and Fedora tries to stay
> away from diverging away from upstream.

Well can't Redhat sponsor the fix and send it upstream.. Sounds like you are
making excuses.
Comment 15 Bill Nottingham 2006-03-23 16:00:35 EST
Realistically, I wonder if it's not better as a local fix, as it is dealing with
a locale extension that is primarily only in glibc (LC_PAPER).
Comment 16 Kyrre Ness Sjøbæk 2007-04-05 08:20:09 EDT
Local fix -> a fix to RH source, forgettabout upstream? I'm no expert, but isn't
glibc quite common under linux anyway?
Comment 17 Matěj Cepl 2007-08-15 09:11:57 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=144625) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.
Comment 18 Matěj Cepl 2007-08-15 09:17:00 EDT
*** Bug 186735 has been marked as a duplicate of this bug. ***
Comment 19 Matěj Cepl 2009-03-10 17:54:15 EDT
*** Bug 445610 has been marked as a duplicate of this bug. ***
Comment 20 Dwayne Bailey 2009-05-28 02:20:39 EDT
The correct upstream bug is:
https://bugzilla.mozilla.org/show_bug.cgi?id=147419

Note You need to log in before you can comment on or make changes to this bug.