Bug 1337778 - [RFE] Decomposition of services into discrete templates
Summary: [RFE] Decomposition of services into discrete templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 10.0 (Newton)
Assignee: Dan Prince
QA Contact: Marius Cornea
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_newton-2 upstream_...
: 1275143 1292328 1292330 1302865 (view as bug list)
Depends On:
Blocks: 1337782 1337784 1367404
TreeView+ depends on / blocked
 
Reported: 2016-05-20 05:05 UTC by Jaromir Coufal
Modified: 2019-10-10 10:24 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:34:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Internal Links: 1367404

Description Jaromir Coufal 2016-05-20 05:05:03 UTC
Blueprint: [see URL]

Break down monolithic controller heat template into discrete set of templates which can be deployed and managed independently.

Comment 1 Carlos Camacho 2016-08-16 13:53:31 UTC
How to test a composable service:

The first item that needs to checked it's to verify that the actual service it's enabled by default in the resource registry. For example, by verifying  in the following file “overcloud-resource-registry-puppet.yaml” that   OS::TripleO::Services::Horizon:  it's not pointing to OS::Heat::None.

Case pointing  to OS::Heat::None.
  In this case the service should be enabled by using an environment file inside the 'environments' folder.

Case pointing to a valid heat template.
  For example “puppet/services/horizon.yaml”, in which case this composable service will be deployed by default.

Note: It's important to check that this resource registry it's not overridden when deploying HA environments, in which case the heat template might be overridden in this environment file “environments/puppet-pacemaker.yaml”

Comment 4 Jaromir Coufal 2016-09-30 08:37:09 UTC
*** Bug 1302865 has been marked as a duplicate of this bug. ***

Comment 5 Jaromir Coufal 2016-09-30 08:46:53 UTC
*** Bug 1275143 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2016-12-14 15:34:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Comment 8 Mike Burns 2017-01-13 16:50:43 UTC
*** Bug 1292328 has been marked as a duplicate of this bug. ***

Comment 9 Mike Burns 2017-01-13 16:51:14 UTC
*** Bug 1292330 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.