Bug 1337782 - [RFE] Customizable roles
Summary: [RFE] Customizable roles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Emilien Macchi
QA Contact: Marius Cornea
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_newton-rc1 upstrea...
: 1245339 1276717 (view as bug list)
Depends On: 1337778 1381841 1381845 1381850 1381852 1381853 1381855 1382144 1382507 1383930 1384524 1385347 1387356 1440918
Blocks: 1236755 1337783 1367611
TreeView+ depends on / blocked
 
Reported: 2016-05-20 05:09 UTC by Jaromir Coufal
Modified: 2017-04-10 18:26 UTC (History)
15 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: Enhancement
Doc Text:
This release now features Composable Roles. TripleO can now be deployed in a composable way, allowing customers to select what services should run on each node. This, in turn, allows support for more complex use-cases.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:34:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Jaromir Coufal 2016-05-20 05:09:54 UTC
Blueprint: [see URL]

Provide user and interface where he can compose discrete services into a single role (node) deployment or deploy them standalone.

Comment 1 Jaromir Coufal 2016-06-08 18:17:05 UTC
*** Bug 1276717 has been marked as a duplicate of this bug. ***

Comment 3 James Slagle 2016-09-20 16:05:46 UTC
this was completed in newton-rc1 but not yet built in brew

Comment 4 Jaromir Coufal 2016-09-30 08:36:45 UTC
*** Bug 1245339 has been marked as a duplicate of this bug. ***

Comment 6 Carlos Camacho 2016-10-07 17:08:10 UTC
Please refer to https://paste.fedoraproject.org/444864/47576058/ 

This shows the current status of the services composability within a new role definition.

Comment 8 errata-xmlrpc 2016-12-14 15:34:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.