Bug 134175 - Gnumeric .desktop file contains invalid mime-type
Gnumeric .desktop file contains invalid mime-type
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
3
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
:
: 134199 134205 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-29 19:30 EDT by Carsten Klein
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 08:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carsten Klein 2004-09-29 19:30:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040928

Description of problem:

Please note: the component is not correct - I did not find the correct
component and as it is related, I just put it in here.

The file /usr/share/applications/gnome-gnumeric.desktop contains an
invalid mime-type:

MimeType=application/x-gnumeric;application/vnd.ms-excel;application/msexcel;application/x-msexcel;application/x-ms-excel;application/vnd.ms-excel;application/x-excel;

-> here is the missing application/ classifier
x-dos_ms_excel;

application/xls;application/x-xls;application/x-applix-spreadsheet;application/vnd.lotus-1-2-3;text/x-comma-separated-values;text/csv;application/csv;application/tab-separated-values;application/x-oleo;application/x-xbase;application/vnd.sun.xml.calc;application/vnd.sun.xml.calc.template;application/x-quattro-pro;application/x-sc;application/x-sylk;application/x-planperfect;application/x-mps;



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Actual Results:  
When performing an update via up2date, debugging information shows
that the update script cannot parse the said .desktop file due to
missing application/ mime-type classifier.


Additional info:
Comment 1 Bryan W Clark 2004-09-30 03:23:16 EDT
I have the latest and it seems to contain this error. 

[clarkbw@rhbw ~]$ rpm -qv gnumeric
gnumeric-1.2.13-2

However I checked out the CVS version [1] which appears to be fixed. 
We just need to update to the latest upstream.

http://cvs.gnome.org/viewcvs/gnumeric/gnumeric.desktop.in?r1=1.20&r2=1.21
Comment 2 Caolan McNamara 2004-09-30 03:58:35 EDT
*** Bug 134199 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2004-09-30 03:58:56 EDT
*** Bug 134205 has been marked as a duplicate of this bug. ***
Comment 4 Caolan McNamara 2004-09-30 04:00:52 EDT
The same bare entry exists in that upstream devel gnumeric.desktop.in
as well so that's not a suitable replacement. I'll remove the
offending odd looking MimeType and respin...
Comment 5 Sarantis Paskalis 2004-09-30 05:46:49 EDT
The desktop patch (gnumeric-1.2.13-desktop.patch) in the srpm is
wrong.  Please add "application/" before "x-dos_ms_excel" in the patch.

The same mimetype is also present in gnumeric.keys.in, but the desktop
patch removes its use, so...

Comment 6 Caolan McNamara 2004-10-01 08:33:20 EDT
should be ok with gnumeric 1.2.13 >= -4

Note You need to log in before you can comment on or make changes to this bug.