Bug 1344686 - tiering : Multiple brick processes crashed on tiered volume while taking snapshots
Summary: tiering : Multiple brick processes crashed on tiered volume while taking snap...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1344651
Blocks: 1346132 1346133
TreeView+ depends on / blocked
 
Reported: 2016-06-10 11:05 UTC by Avra Sengupta
Modified: 2017-03-27 18:24 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1344651
: 1346132 1346133 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:24:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-06-10 11:06:31 UTC
REVIEW: http://review.gluster.org/14696 (tiering/ctr: Fix strcpy coverity) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-06-10 14:39:07 UTC
COMMIT: http://review.gluster.org/14696 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3474aa85e399a92d3ee9159a2d066d4bd73611a0
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jun 10 16:33:04 2016 +0530

    tiering/ctr: Fix strcpy coverity
    
    Change-Id: I6cffba3e09a023f105dbf2975cc9a3ae1a965c31
    BUG: 1344686
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/14696
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Shyamsundar 2017-03-27 18:24:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.