Bug 1346132 - tiering : Multiple brick processes crashed on tiered volume while taking snapshots
Summary: tiering : Multiple brick processes crashed on tiered volume while taking snap...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.12
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1344651 1344686 1346133
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-14 05:51 UTC by Avra Sengupta
Modified: 2016-06-28 12:19 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1344686
Environment:
Last Closed: 2016-06-28 12:19:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-06-14 05:51:56 UTC
REVIEW: http://review.gluster.org/14720 (tiering/ctr: Fix strcpy coverity) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-06-14 13:51:17 UTC
COMMIT: http://review.gluster.org/14720 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 45ae064a03e9d7864316723d7c258698f03dbc52
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jun 10 16:33:04 2016 +0530

    tiering/ctr: Fix strcpy coverity
    
        Backport of http://review.gluster.org/#/c/14696/
    
    Change-Id: I6cffba3e09a023f105dbf2975cc9a3ae1a965c31
    BUG: 1346132
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/14696
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    (cherry picked from commit 3474aa85e399a92d3ee9159a2d066d4bd73611a0)
    Reviewed-on: http://review.gluster.org/14720
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2016-06-28 12:19:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.