Bug 1346133 - tiering : Multiple brick processes crashed on tiered volume while taking snapshots
Summary: tiering : Multiple brick processes crashed on tiered volume while taking snap...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.8.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1344651 1344686
Blocks: 1346132
TreeView+ depends on / blocked
 
Reported: 2016-06-14 05:53 UTC by Avra Sengupta
Modified: 2016-08-12 09:46 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1344686
Environment:
Last Closed: 2016-08-12 09:46:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-06-14 05:54:46 UTC
REVIEW: http://review.gluster.org/14721 (tiering/ctr: Fix strcpy coverity) posted (#1) for review on release-3.8 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-07-21 04:48:47 UTC
REVIEW: http://review.gluster.org/14721 (tiering/ctr: Fix strcpy coverity) posted (#2) for review on release-3.8 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Vijay Bellur 2016-07-22 17:41:23 UTC
COMMIT: http://review.gluster.org/14721 committed in release-3.8 by Vijay Bellur (vbellur@redhat.com) 
------
commit 6f037c46c2a015cad37430fd18052bbf6bfffc5c
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jun 10 16:33:04 2016 +0530

    tiering/ctr: Fix strcpy coverity
    
    This patch is without a testcase, because it needs additional modification to the existing build method to hit the scenario this fix is intended for, and hence writing a testcase alone won't suffice.
    
        Backport of http://review.gluster.org/#/c/14696/
    
    
    > Reviewed-on: http://review.gluster.org/14696
    > Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit 3474aa85e399a92d3ee9159a2d066d4bd73611a0)
    
    Change-Id: I6cffba3e09a023f105dbf2975cc9a3ae1a965c31
    BUG: 1346133
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/14721
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Niels de Vos 2016-08-12 09:46:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.