Bug 134503 - s-c-display doesn't set up synaptics
Summary: s-c-display doesn't set up synaptics
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
: 135482 135491 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-04 04:27 UTC by Bill Nottingham
Modified: 2014-03-17 02:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 15:44:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/bus/input/devices (638 bytes, text/plain)
2004-10-04 04:28 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2004-10-04 04:27:11 UTC
With the import rhpl.mouse added to xconf.py, it does not
set up synaptics in xorg.conf.

# rpm -q synaptics rhpl system-config-display system-config-mouse
synaptics-0.13.5-5
rhpl-0.146-1
system-config-display-1.0.20-1
system-config-mouse-1.2.8-1

Comment 1 Bill Nottingham 2004-10-04 04:28:11 UTC
Created attachment 104701 [details]
/proc/bus/input/devices

Comment 2 Paul Nasrat 2004-10-04 08:28:41 UTC
You've got two devices provided by synaptics, currently (and
historical) we take the first one returned by kudzu.probe in
rhpl.mouse.  I need to add support to handle this case.

Comment 3 Alexandre Oliva 2004-10-04 15:04:45 UTC
FWIW, at least in my case (Dell Dualpoint (TM)), it's not that we get
two devices provided by synaptics, but rather the pointing stick gets
one device and the touchpad gets another.  My /proc/bus/input/devices
looks very similar to the one Bill attached to Comment #1.

Comment 4 Alexandre Oliva 2004-10-04 15:07:47 UTC
I suggest that we mark this as target for FC3, just like bug #116091,
since I suspect the most common set up of touchpads is in addition to
a regular mouse.  Even in notebooks that only have a touchpad, an
external mouse is generally supported as well, quite often with a
keyboard/mouse PS/2 port.

Comment 5 Paul Nasrat 2004-10-04 15:27:21 UTC
Thanks for adding to the target bug, slipped my mind.

I'm wondering if I can have a udev rule ala the wacom tablets:

KERNEL="event*", SYSFS{manufacturer}="WACOM", NAME="input/%k",
SYMLINK="input/wacom%e"

To create /dev/input/touchpadN (as theoretically we could get ALPS
support later).   This would also mean not needing to use auto-dev in
the synaptics config.  That way I don't need to majorly change the
rhpl.mouse api for FC3.  As everything is in /dev/input/mice anyway as
long as the config is sane, multi-device should work (IIRC the config
I generate currently works for adding a usb mouse in addition anyway).


Comment 6 Alexandre Oliva 2004-10-04 18:12:42 UTC
Err...  /dev/input/mice sure works for moving the pointer around, but
tap-to-click, scrolling and all the other niceties of a touchpad will
only work if there's a specific section in the xorg.conf that sets
this stuff up.  I thought you already knew this, but the comment above
gave me the impression that maybe you didn't.

Comment 7 Paul Nasrat 2004-10-04 18:17:03 UTC
Yes I'm aware that you need to use the raw event device for synaptics,
I  think I was unclear - I was trying to say that for non-synaptics
mice configuring for /dev/input/mice is fine.  

I'm thinking of the configs I'm generationg for wacom where the tablet
is an additional input device so multi-device works fine (once I've
got that bit merged).

Anyway hope to have something in place this week...


Comment 8 Paul Nasrat 2004-10-08 13:14:08 UTC
Fix commited to HEAD.

Comment 9 Paul Nasrat 2004-10-13 08:06:16 UTC
*** Bug 135491 has been marked as a duplicate of this bug. ***

Comment 10 Paul Nasrat 2004-10-14 08:34:57 UTC
rhpl 0.148-1 contains fix

Comment 11 Paul Nasrat 2004-10-14 08:36:17 UTC
*** Bug 135482 has been marked as a duplicate of this bug. ***

Comment 12 Charles R. Anderson 2004-10-17 21:26:44 UTC
The fix works for me on dual-input synaptics (pointing-stick +
touchpad) on two laptops, new IBM ThinkPad T42p and 4-year old HP
Omnibook 6000.  These were fresh installs of 200410150526.  Thanks for
getting this support into FC!



Note You need to log in before you can comment on or make changes to this bug.