Bug 134701 - Unable to add searchplugins
Unable to add searchplugins
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 145862 163371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 13:22 EDT by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
18 users (show)

See Also:
Fixed In Version: unsure
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 05:18:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
profile based search plugins (4.52 KB, patch)
2004-12-18 07:49 EST, Oskari Saarenmaa
no flags Details | Diff

  None (edit)
Description Daniel Malmgren 2004-10-05 13:22:03 EDT
Description of problem:
Nothing happens when I try to add new search plugins to firefox

Version-Release number of selected component (if applicable):
firefox-0.10.1-1.0PR1.8

How reproducible:
100%

Steps to Reproduce:
1. Click "Add Engines" on the search panel to the top right
2. Click on an engine to add
3. Confirm that you want to install the new engine
  
Actual results:
Nothing

Expected results:
The new search engine should appear in the search engines list

Additional info:
The directory "searchplugins" in the firefox directory of the users
doesn't exist. The searchplugins displayed in the search panel are the
ones in /usr/lib/firefox-0.10.1/searchplugins.
Comment 1 Daniel Malmgren 2004-10-05 13:23:36 EDT
Oh. Just noticed that this works when firefox is started by root. The
search plugins are then installed into
/usr/lib/firefox-0.10.1/searchplugins, guess that's the problem. They
should be installed in the user's own firefox directory, where the
user has got write permissions.
Comment 2 Thomas Woerner 2004-10-13 12:03:21 EDT
There is no user-searchplugin-dir, yet.
Comment 3 Oskari Saarenmaa 2004-12-18 07:49:14 EST
Created attachment 108844 [details]
profile based search plugins

The attached patch implements profile based search plugins.  It is heavily
based on Robin Lu's patch in mozilla.org bug 123315.
Comment 4 Christopher Aillon 2005-01-30 09:58:57 EST
*** Bug 145862 has been marked as a duplicate of this bug. ***
Comment 5 Carlos Rodrigues 2005-03-04 14:43:53 EST
This is still an issue with firefox-1.0.1-2.
Comment 6 Thilo Pfennig 2005-05-06 10:39:00 EDT
still on 1.0.3. this sucks.
Comment 7 Rudolf Kastl 2005-05-27 08:44:55 EDT
still on 1.0.4 and in rawhide.
Comment 8 James Hall 2005-06-09 19:13:38 EDT
I can reproduce this. All versions 1.0.1 thru 1.0.4
Comment 9 Kyle R Maxwell 2005-06-14 10:52:12 EDT
Is the attached patch similar to the way Debian handles it (where they've
evidently fixed the problem according to
https://bugzilla.mozilla.org/show_bug.cgi?id=232638#c46)? Just curious; this is
really an annoying little bug that should be stamped out.
Comment 10 Christopher Aillon 2005-06-14 11:09:36 EDT
https://bugzilla.mozilla.org/show_bug.cgi?id=123315 is the bug where this is
happening.  The Debian patch is broken and has been rejected by mozilla.org already.

There is one issue left with the patch in the bug i referenced (the profile
notification issue in #c55 of that bug) which I will try and get to soon.
Comment 11 Christopher Aillon 2005-07-21 16:37:00 EDT
*** Bug 163371 has been marked as a duplicate of this bug. ***
Comment 12 Christopher Aillon 2005-07-21 16:38:40 EDT
Note that this is now fixed in rawhide by way of deerpark alpha2.  I'll get a
backported patch into FC4 sometime soon.
Comment 13 Marius Andreiana 2005-07-22 02:24:35 EDT
Will this fix work also for browser plugins and extensions? They all dissapear
after firefox upgrade.

Thanks
Comment 14 Jayson Barr 2005-10-08 00:19:09 EDT
(In reply to comment #3)
> Created an attachment (id=108844) [edit]
> profile based search plugins
> 
> The attached patch implements profile based search plugins.  It is heavily
> based on Robin Lu's patch in mozilla.org bug 123315.

how does a simple user implement this patch?
Comment 15 Daniel Malmgren 2006-09-27 05:18:52 EDT
This has worked for ages now. Closing.

Note You need to log in before you can comment on or make changes to this bug.