Bug 134765 - (radeon 7000 dual head) VT switch causes lockup
(radeon 7000 dual head) VT switch causes lockup
Status: CLOSED DUPLICATE of bug 134766
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-10-06 02:55 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-10-06 02:55:18 EDT
Description of problem:
(This is a followup to Bug #134623 which had incorrect or confusing
info.  Read that bug for more info.)

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100
QY [Radeon 7000/VE] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc: Unknown device 1b8a
	Flags: stepping, 66Mhz, medium devsel, IRQ 11
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at ec00 [size=256]
	Memory at ff9f0000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at 80000000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

Radeon 7000 running in dual head locks up when switching VT.  Only X
locks up, while it is possible to ssh into the system.  If you do not
switch VT manually, killing and restarting X works fine.
Xorg.0.log says the following line repeatedly when X locks up:
(EE) RADEON(0): Idle timed out, resetting engine...

Option "NoAccel" prevents this lockup.  "RenderAccel" "No" does not
prevent this lockup, nor does all XaaNo options when used together. 
DRI does not seem to matter as it DRI is unavailable in dual head.

lspci -v

Version-Release number of selected component (if applicable):
Comment 1 Mike A. Harris 2004-10-12 01:12:39 EDT

*** This bug has been marked as a duplicate of 134766 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.