Bug 13494 - Cirrus Logic GD5446/5480
Cirrus Logic GD5446/5480
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 13838 47102 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-05 09:05 EDT by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 06:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2000-07-05 09:05:13 EDT
One machine with a Cirrus Logic GD5446 based display adapter with 1 meg of
video ram shows the first GUI screen in broken up form.  In a text install
when X is configured the X test screen is also broken up.  Using
Xconfigurator after install, the test screen is also broken.

The installation chooses the SVGA server, which I believe is correct.

This card worked fine in RHL 6.2
Comment 1 Pekka Pietikäinen 2000-07-11 11:42:26 EDT
This also happens with the integrated GD 5480 of Intel L440GX+ motherboards.
It is fixed by Option "no_bitblt" in the XF86Config, so maybe it should be
enabled by default for cirrus boards (the later ones anyway?)
Comment 2 Matt Wilson 2000-07-15 15:08:18 EDT
Using the accerated driver in XFree86-4.0 works even better, that's what I've
done in CVS.
Comment 3 Matt Wilson 2000-07-15 15:08:37 EDT
*** Bug 13838 has been marked as a duplicate of this bug. ***
Comment 4 Pekka Pietikäinen 2001-07-02 11:35:51 EDT
Still there in Fairfax. And 3.3.6 is what gets selected
(and 4.0.3 has the same problem)


Comment 5 Pekka Pietikäinen 2001-07-02 11:51:16 EDT
And to avoid confusion, this was about 5480, in the kudzu database it says

# reported not working on SGI 1200 as of 02/22/2001
NAME Cirrus Logic GD5480
CHIPSET CL-GD5480
SERVER SVGA
DRIVER cirrus
UNSUPPORTED 
NOCLOCKPROBE 

00:14.0 Class 0300: 1013:00bc (rev 23)
	Subsystem: 8086:4948
	Flags: bus master, medium devsel, latency 64
	Memory at fc000000 (32-bit, prefetchable) [size=32M]
	Memory at fa006000 (32-bit, non-prefetchable) [size=4K]
	Expansion ROM at <unassigned> [disabled] [size=32K]

I'd suggest a no_bitblt for 3.3.6 on this board (and for 4.0.x
it's something else, maybe just noaccel and be done with it)
Comment 6 Mike A. Harris 2001-07-03 08:25:24 EDT
Reassigning to XFree86 and changing assignee..
Comment 7 Mike A. Harris 2001-07-03 08:27:00 EDT
*** Bug 47102 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2001-07-30 03:59:31 EDT
Somehow this bug got assigned to msw..  Reassigning to myself.
There is a new Cirrus logic fix I've just made in the newest XFree86
4.1.0-0.9.8 package not yet available in rawhide.
Comment 9 Pekka Pietikäinen 2001-08-07 06:27:20 EDT
4.1.0-0.9.11 from rawhide works perfectly for me, even without the
no_bitblt/no_accel workaround.

I changed the bug to Xconfigurator, which needs the following to make it
use 4.1.0 instead of 3.3.6:

--- Cards~	Mon Aug  6 10:57:18 2001
+++ Cards	Tue Aug  7 10:18:23 2001
@@ -228,7 +228,6 @@
 CHIPSET CL-GD5480
 SERVER SVGA
 DRIVER cirrus
-UNSUPPORTED
 NOCLOCKPROBE
 
 #tested

Also make sure anaconda uses 4.1.0 on these boards.

5446 probably needs something similar, but I don't have the hardware
to test if the fix works on those too.
Comment 10 Mike A. Harris 2001-08-19 23:29:19 EDT
The changes to Xconfigurator were made at the same time the bug
was fixed.

Note You need to log in before you can comment on or make changes to this bug.