Bug 1351271 - RFE: Cinder: v3 api option default
Summary: RFE: Cinder: v3 api option default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: lkuchlan
URL:
Whiteboard:
Depends On:
Blocks: 1305654 1351275 1358512 1358513 1358520
TreeView+ depends on / blocked
 
Reported: 2016-06-29 15:00 UTC by Rajini Karthik
Modified: 2017-05-03 15:48 UTC (History)
23 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: Enhancement
Doc Text:
The Red Hat OpenStack Platform director creates OpenStack Block Storage (cinder) v3 API endpoint in OpenStack Identity (keystone) to support the newer Cinder API version.
Clone Of:
: 1351275 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:41:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
Red Hat Bugzilla 1369715 None CLOSED openstack client using v1 api instead of v2 2019-05-01 03:27:42 UTC
Red Hat Bugzilla 1434929 None CLOSED Cinder and Glance API versions 2019-05-01 03:27:42 UTC

Internal Links: 1369715 1434929

Description Rajini Karthik 2016-06-29 15:00:47 UTC
Description of problem:
For mitaka , there is new V3 endpoint and devstack support for v3.

- Test all new cinder features using the Vc3 api (cinder client)
- Decide if we should make it default going forward in OSP9

To check
$ cinder --os-volume-api-version 3.1 --api-version

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Sean Cohen 2016-07-26 18:52:30 UTC
Hi Rajini,
Is there any dependencies for v3 API in JS6.0?
Sean

Comment 3 Rajini Karthik 2016-07-26 19:32:10 UTC
That is the recommended API now (although the base v3 is exactly the same as v2 if you’re not using microversions), but there is no impact on our drivers. Its really optional

Comment 4 Rajini Karthik 2016-07-26 19:32:21 UTC
That is the recommended API now (although the base v3 is exactly the same as v2 if you’re not using microversions), but there is no impact on our drivers. Its really optional

Comment 5 Paul Grist 2016-08-09 22:11:15 UTC
Eric - can you confirm v3 is the default for OSP-10? once we confirm v3 is already the default for OSP10, I think we can close this one out.

Rajini - I would like remove the JS6 dependency. Is there any other reason this bug was marked as a blocker for the others 3 in addition to the JS6 tracker?

Comment 6 Eric Harney 2016-08-11 13:43:26 UTC
(In reply to Paul Grist from comment #5)
> Eric - can you confirm v3 is the default for OSP-10? once we confirm v3 is
> already the default for OSP10, I think we can close this one out.

Yes, Cinder ships with v3 enabled for OSP10.  Director will need to create an endpoint for it.

Comment 8 Elise Gafford 2016-08-22 18:38:24 UTC
Hi Juan,

Your merged patch at https://github.com/openstack/tripleo-heat-templates/commit/1e7bab9653afe37c1e87242c227b45530d013814 appears to address this issue. Can you verify that this patch successfully creates the endpoints for Cinder's v3 API in Keystone?

Thanks for your work!
- Elise

Comment 9 Juan Antonio Osorio 2016-09-05 11:19:40 UTC
that patch only partly addresses the issue. However, the issue should be addressed by this commit which has merged already https://github.com/openstack/tripleo-heat-templates/commit/f34c6a601317b7783885eed6ce16927d7e9337d8 this enabled the creation of the keystone endpoints via puppet, and thus will create the cinder_v3 endpoint with the info provided by the commit you mentioned

Comment 10 Elise Gafford 2016-09-12 22:10:41 UTC
Per josorior, this bug is addressed in the current build of TripleO. Marking as MODIFIED in the current build.

Comment 13 lkuchlan 2016-10-26 16:30:29 UTC
Hi Eric,
Is api v3 should already be as the default option?
As you can see from api.log the default is still v2  

From cinder/api.log:
2016-10-26 16:20:18.501 31610 INFO eventlet.wsgi.server [req-20f185dc-31a9-455f-86f7-1999f22c7c4c 47360029279740eebb60219fab042b52 2783390679524d3d97a70e10c8f7656b - default default] 172.17.1.18 "GET /v2/2783390679524d3d97a70e10c8f7656b/volumes/detail HTTP/1.1" status: 200  len: 253 time: 0.7082100

Comment 15 Eric Harney 2016-11-02 20:54:11 UTC
(In reply to lkuchlan from comment #13)
> Is api v3 should already be as the default option?
> As you can see from api.log the default is still v2  
> 
> From cinder/api.log:
> 2016-10-26 16:20:18.501 31610 INFO eventlet.wsgi.server
> [req-20f185dc-31a9-455f-86f7-1999f22c7c4c 47360029279740eebb60219fab042b52
> 2783390679524d3d97a70e10c8f7656b - default default] 172.17.1.18 "GET
> /v2/2783390679524d3d97a70e10c8f7656b/volumes/detail HTTP/1.1" status: 200 
> len: 253 time: 0.7082100

You will have to opt in to the v3 API by adding "--os-volume-api-version 3" to the cinder CLI command.  The client uses still v2 by default.

Comment 16 lkuchlan 2016-11-06 08:48:31 UTC
Tested using:
openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch

Comment 18 errata-xmlrpc 2016-12-14 15:41:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.