Bug 1434929 - Cinder and Glance API versions
Summary: Cinder and Glance API versions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Alan Bishop
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On: 1425533 1434923
Blocks: 1335596 1356451 1426284 1434928 1434931
TreeView+ depends on / blocked
 
Reported: 2017-03-22 15:52 UTC by Rajini Karthik
Modified: 2018-02-05 19:07 UTC (History)
27 users (show)

Fixed In Version: openstack-tripleo-common-7.1.1-0.20170616124957.93d87e0.el7ost
Doc Type: Enhancement
Doc Text:
Previously, the OS_IMAGE_API_VERSION and the OS_VOLUME_API_VERSION environment variables were not set, which forced Glance and Cinder to fall back to the default API versions. For Cinder, this was the older v2 API. With this update, the overcloudrc file now sets the environment variables to specify the API versions for Glance and Cinder.
Clone Of: 1434923
: 1434931 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:20:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC
OpenStack gerrit 473540 None None None 2017-06-12 17:25:28 UTC
Red Hat Bugzilla 1351271 None CLOSED RFE: Cinder: v3 api option default 2019-06-18 10:24:38 UTC

Internal Links: 1351271

Description Rajini Karthik 2017-03-22 15:52:11 UTC
+++ This bug was initially created as a clone of Bug #1434923 +++

Description of problem:
Glance should usee v2.3 and Cinder should use v3 as the default api version for OSP10.
Tracker - https://bugzilla.redhat.com/show_bug.cgi?id=1426284

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Alan Bishop 2017-05-18 20:29:57 UTC
I want to clarify that we're talking about the API used by the CLI (both the cinder and osc versions). The cinder v3 endpoint was added in OSP-10 (see bug #1351271), but I confirmed both CLIs still default to v2. BTW, osc client support for cinder v3 was just added in Pike.

Rajini, please confirm it's just the CLI versions that need to be bumped to v3.

Comment 3 Alan Bishop 2017-05-18 20:55:37 UTC
It seems upstream support for cinder v3 in python-openstackclient (osc) is only a stub, and content is just being added [1]. I think the best we can hope for in the short term is to get python-cinderclient bumped to v3.

[1] https://review.openstack.org/#/c/421585/

Comment 4 Rajini Karthik 2017-05-19 15:18:22 UTC
1. We should also authenticate using identity server API V3
This requires the overcloudrc to be changed
Since Block Storage API V2 is officially deprecated, we should to set OS_VOLUME_API_VERSION=3. Also set the OS_AUTH_URL to the keystone endpoint:

export OS_AUTH_URL=http://controller:5000/v3
export OS_VOLUME_API_VERSION=3

2.If a user makes a request without specifying a version, they will get the DEFAULT_API_VERSION as defined in cinder/api/openstack/api_version_request.py.
Althought I'm not sure if this needs to be updated

3. Cinder V3 endpoint should be created in keystone
openstack endpoint show cinderv3

Comment 5 Alan Bishop 2017-06-16 12:29:42 UTC
Patch has been merged upstream, will update the BZ status once it's include in a build.

Comment 13 Alan Bishop 2017-07-17 11:57:51 UTC
Clearing needsinfo (info provided in comment #11).

Comment 19 errata-xmlrpc 2017-12-13 21:20:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.