Bug 1353495 - [Consume] An unknown error occurred during anaconda interactive installation on an iSCSI LUN (consume bug 1269195)
Summary: [Consume] An unknown error occurred during anaconda interactive installation ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.1.0-beta
: 4.1
Assignee: Ryan Barry
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On: 1269195 1361113
Blocks: ovirt-node-ng-platform 1381246
TreeView+ depends on / blocked
 
Reported: 2016-07-07 09:49 UTC by cshao
Modified: 2017-02-01 14:56 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, RHV-H could not be installed on a system presenting a large number of iSCSI LUNs to Anaconda. This installation scenario now works as expected.
Clone Of:
Environment:
Last Closed: 2017-02-01 14:56:57 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
fdeutsch: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
all log info (402.10 KB, application/x-gzip)
2016-07-07 09:49 UTC, cshao
no flags Details
anaconda-failed (73.07 KB, image/png)
2016-07-07 09:50 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1325134 None CLOSED Anaconda disallows installing booloader to offload iSCSI device (qla4xxx) 2019-04-02 00:37:22 UTC

Internal Links: 1325134

Description cshao 2016-07-07 09:49:40 UTC
Created attachment 1177237 [details]
all log info

Description of problem:
An unknown error occurred during anaconda interactive installation.

ks:
liveimg --url=http://10.66.10.22:8090/rhevh/rhevh7-ng-36/rhev-hypervisor7-ng-4.0-20160701.1/rhev-hypervisor7-ng-4.0-20160701.1.x86_64.liveimg.squashfs

Version-Release number of selected component (if applicable):
RHEV-H-7.2-20160701.2-RHVH-x86_64-dvd1.iso
redhat-release-rhev-hypervisor-4.0-0.9.el7.x86_64


How reproducible:
50%

Steps to Reproduce:
1. Boot from PXE and anaconda interactive installation RHVH on DellR-515-02(The machine has more than 20 iSCSI luns)
2. Try to finish the installation with correct steps.
3. Focus on the installation process.
4. Please see the attachment for more detail.

Actual results:
An unknown error occurred during anaconda interactive installation.

Expected results:
No error occurred during anaconda interactive installation.

Additional info:
No such issue on other iscsi machine(e.g. dellR510-01 which has 2 iSCSI luns)

Comment 1 cshao 2016-07-07 09:50:59 UTC
Created attachment 1177238 [details]
anaconda-failed

Comment 2 Ryan Barry 2016-07-07 12:18:44 UTC
Thie appears to be a duplicate of bz#1269195

That bug is ON_QA, and we cherry-picked the commit associated with that bug-url back into the Anaconda build, but looking at the patch, I'm not sure how this resolves.

Vojtech, is https://github.com/evol262/anaconda/commit/baffbc3544f6a355f4ff2b3553cb9431800ff74a the right patch?

Comment 3 Ryan Barry 2016-07-07 12:31:04 UTC
Chen, were you trying to install on an iSCSI LUN?

Comment 4 cshao 2016-07-07 13:16:47 UTC
(In reply to Ryan Barry from comment #3)
> Chen, were you trying to install on an iSCSI LUN?

Yes, the issue just occurs on an iSCSI LUN.(The machine has more than 20 iSCSI luns)

Comment 5 Vojtech Trefny 2016-07-19 11:06:32 UTC
From anaconda.log: "11:22:45,826 ERR anaconda: BootLoader setup failed: failed to find a suitable stage1 device"

The problem here is we start installation without having a stage1 device. The patch Ryan Barry mentioned just makes sure Anaconda doesn't start installation in such cases -- it will just show the error and let the user manually fix the configuration.

Comment 6 Fabian Deutsch 2016-07-21 12:26:17 UTC
Chen, just verifying: Is this machine using an HBA?

Vojtech, isn't a LUN which is connected through an HBA a suitable stage1 device?

Or what is the way to install RHEL on a system with only LUNs connected thorugh an HBA?

Comment 7 Radek Vykydal 2016-07-21 12:47:11 UTC
We have allowed installing bootloader to offload iSCSI devices in bug #1325134 [1] which I believe should apply also to the case from description.

[1] anaconda: https://github.com/rhinstaller/anaconda/commit/404d7f8951f62ed661a3bcf0
blivet: https://github.com/rhinstaller/blivet/commit/c70779194daf1ed43a5c03529e2ee088762855f9

Comment 8 cshao 2016-07-21 12:49:07 UTC
(In reply to Fabian Deutsch from comment #6)
> Chen, just verifying: Is this machine using an HBA?
Yes.

Comment 9 Fabian Deutsch 2016-07-21 13:31:08 UTC
Thanks.

Because two packages, anaconda and blivet, are required to fix this, this probably needs to wait until 7.3.

Comment 10 Ryan Barry 2016-09-30 15:47:18 UTC
Can you please test this on the 7.3 distill?

Comment 11 Fabian Deutsch 2016-10-04 08:11:56 UTC
*** Bug 1381246 has been marked as a duplicate of this bug. ***

Comment 12 cshao 2016-10-08 09:39:48 UTC
(In reply to Ryan Barry from comment #10)
> Can you please test this on the 7.3 distill?

I will update test result ASAP.

Comment 13 jianwu 2016-10-10 10:07:00 UTC
Hi,
   when install RHEV-H-7.2-20161007.0-RHVH-x86_64-dvd1.iso

situation 1:

on dell-pet105-01, single path iscsi machine

can install the RHVH successfully and login by "root" and password.

situation 2:

on dell-pet515-02, multiLUN and single path iscsi machine

can install the RHVH successfully and login by "root" and password.

situation 3:

on dell-z800-02, mulipath iscsi machine

can install the RHVH successfully and login by "root" and password.

but first reboot: cannot enter login option
    second reboot: it work successfully.

Additional info:

all the above could success when you must choose the same disk to the previous installation, if change the disk option, there will be a mistake when install.

Comment 14 cshao 2016-10-10 10:19:26 UTC
(In reply to jianwu from comment #13)
> Hi,
>    when install RHEV-H-7.2-20161007.0-RHVH-x86_64-dvd1.iso
> 
> situation 1:
> 
> on dell-pet105-01, single path iscsi machine
> 
> can install the RHVH successfully and login by "root" and password.
> 
> situation 2:
> 
> on dell-pet515-02, multiLUN and single path iscsi machine
> 
> can install the RHVH successfully and login by "root" and password.
> 
> situation 3:
> 
> on dell-z800-02, mulipath iscsi machine
> 
> can install the RHVH successfully and login by "root" and password.
> 
> but first reboot: cannot enter login option
>     second reboot: it work successfully.
> 
> Additional info:
> 
> all the above could success when you must choose the same disk to the
> previous installation, if change the disk option, there will be a mistake
> when install.

Thanks jiawu for the detail testing.

According this test result, the original bug is fixed. You can report a new bug to trace the the new issue.

Hi Ryan,

Could you help to fill the "Fixed In Version" area with suitable info, then I will verify this bug.

Thanks.

Comment 15 Ying Cui 2016-10-13 00:25:23 UTC
This bug is targeted to ovirt-4.1, the RHVH 4.1 build is not ready to QE. We won't verify this bug. and we have to move back to MODIFIED status.

Comment 20 Qin Yuan 2017-01-18 10:33:49 UTC
Test Versions:
redhat-virtualization-host-4.1-20170116.0
imgbased-0.9.4-0.1.el7ev.noarch

Test Steps:
Install redhat-virtualization-host-4.1-20170116.0 on dell-per515-02 having 21 iscsi luns
1. Choose all luns to install RHVH
2. Only choose one lun to install RHVH

Test Results:
1. RHVH can be installed on all 21 iscsi luns.
2. RHVH can be installed on only one iscsi lun.

So, RHVH can be installed on system having a large number of iscsi luns. Set the bug's status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.