Bug 135935 - No email address for the reporters when using the beta bugzilla
Summary: No email address for the reporters when using the beta bugzilla
Status: CLOSED RAWHIDE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.18
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 135819 135957 136260 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 20:07 UTC by Suzanne Hillman
Modified: 2007-04-18 17:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 22:21:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suzanne Hillman 2004-10-15 20:07:14 UTC
Description of problem: There is no email address for the reporter, when looking
at an individual bug. This can make it difficult to know where to direct people,
and/or whether or not a feature request can go directly into featurezilla
(internal requests), or if a featurezilla needs to be created separately and
pointed to.

Steps to Reproduce:
1. Go to a bug in bugzilla's beta (Eg
https://bugzilla.redhat.com/beta1/show_bug.cgi?id=135313)
2. Notice that there is only a reporter name, and not an address
3.
  
Actual results:
No email address for the reporter!

Expected results:
Email address either being in the bug, or easily found via a link from the bug,
so I can tell where things need to be directed during triage.


Additional info:

Comment 1 David Lawrence 2004-10-18 22:34:43 UTC
*** Bug 135957 has been marked as a duplicate of this bug. ***

Comment 2 David Lawrence 2004-10-18 22:35:32 UTC
*** Bug 136260 has been marked as a duplicate of this bug. ***

Comment 3 David Lawrence 2004-10-18 22:43:46 UTC
*** Bug 135819 has been marked as a duplicate of this bug. ***

Comment 4 David Lawrence 2004-10-18 22:50:10 UTC
My original reasoning for doing this was to keep all communication inside of
Bugzilla by forcing people to use the  ui interface. Also I had complaints using
the old Bugzilla about the possibilty of spam bots farming email addresses from
public bug reports. My three options here that I would like comment on are:

1. Only show email addresses if viewer logged in with a proper account.
Wondering though if someone can create scripts that log with valid accounts and
farm emails that way.

2. Convert all user@domain.com emails to "user AT domain_com" or something
similar and then force the user to fix the address in their client before
sending a message.

3. Leave it as is.

Any other methods or comments?

Dave

Comment 5 Mike McLean 2004-10-18 23:10:32 UTC
perhaps only show emails to privileged accounts


Comment 6 Suzanne Hillman 2004-10-19 15:23:46 UTC
I'm fine with either 1 or 2, since I only need the address to know
where a bug originated from.

Comment 7 David Lawrence 2004-10-25 22:21:47 UTC
Fixed in new beta, https://bugzilla.redhat.com/beta2


Note You need to log in before you can comment on or make changes to this bug.