Bug 136109 - lftp-3.0.6-2 spins in a tight loop
lftp-3.0.6-2 spins in a tight loop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lftp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
: 136126 136299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-17 18:44 EDT by Charles R. Anderson
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.9-1.637
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 10:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace lftp output (437.81 KB, text/plain)
2004-10-17 18:45 EDT, Charles R. Anderson
no flags Details
proposed patch to fix lftp (407 bytes, patch)
2004-10-19 06:05 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Charles R. Anderson 2004-10-17 18:44:17 EDT
Description of problem:

lftp doesn't work--it spins in a tight loop, moving the cursor back
and forth, never giving a prompt, regardless of command line options
provided.

Version-Release number of selected component (if applicable):

3.0.6-2

How reproducible:

sometimes, on two different systems

Steps to Reproduce:
1.  run "lftp"
2.  watch cursor move from column 1 to 3 and back again
3.  ctrl-c to quit
  
Additional info:

See attached strace.
Comment 1 Charles R. Anderson 2004-10-17 18:45:09 EDT
Created attachment 105357 [details]
strace lftp output
Comment 2 Bill Nottingham 2004-10-17 23:17:59 EDT
This is due to the O_NONBLOCK changes in kernel-2.6.8-1.624
Comment 3 Bill Nottingham 2004-10-18 00:12:30 EDT
*** Bug 136126 has been marked as a duplicate of this bug. ***
Comment 4 Jason Vas Dias 2004-10-18 12:21:20 EDT
 Just rebuilding the src.rpm fixes this problem .
 The lftp package had not been rebuilt since August 16th, and there
 had been alot of glibc changes since then.
 I've now rebuilt lftp and submitted it to FC3 as lftp-3.0.6-3 - I 
 can't reproduce the problem with this version.

 
Comment 5 Jeffrey Moyer 2004-10-18 12:25:53 EDT
I think the key is the kernel version, as Bill mentioned.  Dave backed
out the O_NONBLOCK patch, and that should be what fixed the problem.
Comment 6 Jason Vas Dias 2004-10-18 12:33:40 EDT
 testing with rawhide-latest of today (10-18-2004), kernel-2.6.8-1.624,
 glibc-2.3.3-68, installing the rawhide lftp RPM causes this problem
 to be 100% reproducible. Just rebuilding the src.rpm and installing
 the rebuilt packages makes this problem 100% unreproducible. I can't
 see how it can be a kernel problem - I think the package just needed
 rebuilding against the new glibc & /usr/include headers, which have
 changed since August 16th 2004, when the current rawhide lftp-3.0.6-2 
 package was built.
Comment 7 Jeffrey Moyer 2004-10-18 12:35:24 EDT
Well, I can't argue with that!
Comment 8 Jason Vas Dias 2004-10-18 13:21:32 EDT
 This is very weird - perhaps it is a kernel issue after all:
  1. I rebuild and install the lftp packages - problem disappears.
  2. I reboot - problem reappears.
 Rebuilding and installing then immediately fixes the problem;
 reboot and it starts happening again.
 I'll retest when the O_NONBLOCK patch is backed out.
 
Comment 9 Harald Hoyer 2004-10-19 05:42:22 EDT
*** Bug 136299 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2004-10-19 06:05:58 EDT
Created attachment 105436 [details]
proposed patch to fix lftp
Comment 11 Jason Vas Dias 2004-10-20 10:13:54 EDT
This problem is now fixed with kernel-2.6.9-1.637 .

Note You need to log in before you can comment on or make changes to this bug.