This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 136197 - [FHS] mozilla creates files not tracked by RPM in /usr/lib/mozilla-1.7.3/chrome/, others
[FHS] mozilla creates files not tracked by RPM in /usr/lib/mozilla-1.7.3/chro...
Status: CLOSED DUPLICATE of bug 74160
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 13:58 EDT by Daniel Reed
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 05:45:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
list of all files in /usr/lib/mozilla-1.7.3/ that are in neither rpmdb nor rpmdb-fedora (1.34 KB, text/plain)
2004-10-18 13:58 EDT, Daniel Reed
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 136015 None None None Never

  None (edit)
Description Daniel Reed 2004-10-18 13:58:23 EDT
*** This bug has been split off bug 136015 ***

After an installation of Fedora Core rawhide, an unknown process modifies files
in the path ``/usr/lib/mozilla-1.7.3/chrome/'' and others under the path
``/usr/lib/mozilla-1.7.3/''.

``/usr/lib/mozilla-1.7.3/chrome/'' is owned by the package ``mozilla''.


http://www.pathname.com/fhs/pub/fhs-2.3.html#THEUSRHIERARCHY

``/usr is the second major section of the filesystem. /usr is shareable,
read-only data. That means that /usr should be shareable between various
FHS-compliant hosts and must not be written to. Any information that is
host-specific or varies with time is stored elsewhere.''

http://www.pathname.com/fhs/pub/fhs-2.3.html#USRLIBLIBRARIESFORPROGRAMMINGANDPA

``/usr/lib includes object files, libraries, and internal binaries that are not
intended to be executed directly by users or shell scripts.''



The files in these various hierarchies do not appear to be object files,
libraries, nor internal binaries, but data files. They also do not appear to
have been updated except during package management. However, they are not
tracked by package management as they were [apparently] generated at install
time and left unassociated with the package they were generated by. If the data
can not or should not be generated on the fly, it may be best suited for storage
in the ``/var/cache'' hierarchy.

http://www.pathname.com/fhs/pub/fhs-2.3.html#VARCACHEAPPLICATIONCACHEDATA

``/var/cache is intended for cached data from applications. Such data is locally
generated as a result of time-consuming I/O or calculation. The application must
be able to regenerate or restore the data. Unlike /var/spool, the cached files
can be deleted without data loss. The data must remain valid between invocations
of the application and rebooting the system.''
Comment 1 Daniel Reed 2004-10-18 13:58:24 EDT
Created attachment 105392 [details]
list of all files in /usr/lib/mozilla-1.7.3/ that are in neither rpmdb nor rpmdb-fedora
Comment 2 Christopher Aillon 2005-03-31 05:45:22 EST

*** This bug has been marked as a duplicate of 74160 ***

Note You need to log in before you can comment on or make changes to this bug.