Bug 1371540 - Spurious regression in tests/basic/gfapi/bug1291259.t
Summary: Spurious regression in tests/basic/gfapi/bug1291259.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1376390
TreeView+ depends on / blocked
 
Reported: 2016-08-30 12:36 UTC by Poornima G
Modified: 2017-03-06 17:24 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376390 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:24:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-08-30 12:36:57 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Poornima G 2016-08-30 12:37:46 UTC
Regression on ./tests/basic/gfapi/bug1291259.t has failed 12 times in last 7 days.
	Regression Link: http://build.gluster.org/job/centos6-regression/363/consoleText
	Node: slave27.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/355/consoleText
	Node: slave33.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/322/consoleText
	Node: slave25.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/297/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/290/consoleText
	Node: slave33.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/287/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/282/consoleText
	Node: slave24.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/250/consoleText
	Node: slave25.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/246/consoleText
	Node: slave26.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/232/consoleText
	Node: slave24.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/213/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/187/consoleText
	Node: slave33.cloud.gluster.org

Comment 2 Worker Ant 2016-08-30 12:43:36 UTC
REVIEW: http://review.gluster.org/15353 (gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Worker Ant 2016-09-01 09:24:18 UTC
COMMIT: http://review.gluster.org/15353 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 4ac0cf9c7ba7d98cc21b88aa6d7aa9f7c8884a67
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Aug 30 18:10:16 2016 +0530

    gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed
    
    Change-Id: Ia0493ce7e71050b3e8a1a1fed2d861cc141a0f94
    BUG: 1371540
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/15353
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

Comment 4 rjoseph 2016-09-15 09:21:03 UTC
This patch only disables the test case. I guess the purpose of this bug is to fix the failure.

Therefore moving the bug to ASSIGNED state.

Comment 5 Worker Ant 2016-09-30 11:00:10 UTC
REVIEW: http://review.gluster.org/15603 (tests: gfapi/bug1291259.c should only call glfs_free() on success) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 6 Worker Ant 2016-10-20 13:13:34 UTC
COMMIT: http://review.gluster.org/15603 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit d73ca4a5bfad1e46dfc4a3a12401d8720b05c298
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Sep 30 12:55:40 2016 +0200

    tests: gfapi/bug1291259.c should only call glfs_free() on success
    
    In case glfs_h_poll_upcall() does not return success, the 'struct
    glfs_upcall' would not have been allocated. A retry will be done and
    glfs_free() is called on the unallocated structure. In case the pointer
    does not point to NULL, glfs_free() will try to free up some random
    area.
    
    Change-Id: I38788d3bf22bbac3924f25edf45cd4a2637fa777
    BUG: 1371540
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/15603
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>

Comment 7 Shyamsundar 2017-03-06 17:24:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.