Bug 1376390 - Spurious regression in tests/basic/gfapi/bug1291259.t
Summary: Spurious regression in tests/basic/gfapi/bug1291259.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rjoseph
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1371540
Blocks: 1347717
TreeView+ depends on / blocked
 
Reported: 2016-09-15 10:10 UTC by rjoseph
Modified: 2016-10-20 14:03 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1371540
Environment:
Last Closed: 2016-10-20 14:03:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description rjoseph 2016-09-15 10:10:40 UTC
+++ This bug was initially created as a clone of Bug #1371540 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Poornima G on 2016-08-30 08:37:46 EDT ---

Regression on ./tests/basic/gfapi/bug1291259.t has failed 12 times in last 7 days.
	Regression Link: http://build.gluster.org/job/centos6-regression/363/consoleText
	Node: slave27.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/355/consoleText
	Node: slave33.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/322/consoleText
	Node: slave25.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/297/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/290/consoleText
	Node: slave33.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/287/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/282/consoleText
	Node: slave24.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/250/consoleText
	Node: slave25.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/246/consoleText
	Node: slave26.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/232/consoleText
	Node: slave24.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/213/consoleText
	Node: slave1.cloud.gluster.org
	Regression Link: http://build.gluster.org/job/centos6-regression/187/consoleText
	Node: slave33.cloud.gluster.org

--- Additional comment from Worker Ant on 2016-08-30 08:43:36 EDT ---

REVIEW: http://review.gluster.org/15353 (gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2016-09-01 05:24:18 EDT ---

COMMIT: http://review.gluster.org/15353 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 4ac0cf9c7ba7d98cc21b88aa6d7aa9f7c8884a67
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Aug 30 18:10:16 2016 +0530

    gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed
    
    Change-Id: Ia0493ce7e71050b3e8a1a1fed2d861cc141a0f94
    BUG: 1371540
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/15353
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

--- Additional comment from  on 2016-09-15 05:21:03 EDT ---

This patch only disables the test case. I guess the purpose of this bug is to fix the failure.

Therefore moving the bug to ASSIGNED state.

Comment 1 Worker Ant 2016-09-15 10:22:01 UTC
REVIEW: http://review.gluster.org/15505 (gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed) posted (#1) for review on release-3.8 by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Worker Ant 2016-09-21 10:20:27 UTC
COMMIT: http://review.gluster.org/15505 committed in release-3.8 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 52b3e331fcef2bd707ec0fc3c354f6b870343525
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Aug 30 18:10:16 2016 +0530

    gfapi: Mark tests/basic/gfapi/bug1291259.t bad until it is fixed
    
    > Change-Id: Ia0493ce7e71050b3e8a1a1fed2d861cc141a0f94
    > BUG: 1371540
    > Signed-off-by: Poornima G <pgurusid@redhat.com>
    > Reviewed-on: http://review.gluster.org/15353
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    
    BUG: 1376390
    Change-Id: I21d7d78e64a55eafe70afe24d73cfafb7b8e64ad
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/15505
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>

Comment 3 Niels de Vos 2016-09-30 11:09:30 UTC
This test-case will be corrected with the patch for bug 1347717.

Comment 4 Niels de Vos 2016-10-20 14:03:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.5, please open a new bug report.

glusterfs-3.8.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-October/000061.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.