Bug 13727 - RH 7.0 beta 3 and CS 4614
Summary: RH 7.0 beta 3 and CS 4614
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 13728 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-11 15:22 UTC by Rogelio Noriega
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-28 19:17:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2.2.17pre14->15 patch (2.37 KB, patch)
2000-08-01 09:54 UTC, Alan Cox
no flags Details | Diff

Description Rogelio Noriega 2000-07-11 15:22:36 UTC
Dell Precision 420 and 620

Recognized CS4614 audio chipset using sndconfig but not support.

Comment 1 Bill Nottingham 2000-07-11 15:45:04 UTC
*** Bug 13728 has been marked as a duplicate of this bug. ***

Comment 2 Glen Foster 2000-07-18 20:16:03 UTC
This defect is considered MUST-FIX for Winston Beta-5


Comment 3 Bill Nottingham 2000-07-18 20:18:47 UTC
This is not a sndconfig problem; this is a kernel problem.
(no driver)

Comment 4 Glen Foster 2000-07-21 20:32:26 UTC
This defect has been re-classified as MUST-FIX for Winston Gold-release

Comment 5 Rogelio Noriega 2000-07-25 02:09:03 UTC
*Beta 4 did not fix the problem.

Comment 6 Glen Foster 2000-07-30 22:51:58 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Sorry for the priority/deadline changes -- getting the process right.

Comment 7 Bill Nottingham 2000-07-31 14:38:14 UTC
This should be fixed in beta5; if not, please re-open.

Comment 8 Rogelio Noriega 2000-07-31 22:16:04 UTC
Please re-open works partially in beta 5 only in GNOME and KDE if ran from 
command line audio is very distorted. 

CS4614
Vendor ID 1013
Device ID 6003

Comment 9 Alan Cox 2000-08-01 09:53:31 UTC
There are a couple of obvious bugs in cs46xx that would trip up some
applications. Please try
the attached patch. This might also fix your sox traces Bill.

Alan


Comment 10 Alan Cox 2000-08-01 09:54:09 UTC
Created attachment 1738 [details]
2.2.17pre14->15 patch

Comment 11 Bill Nottingham 2000-08-01 21:26:05 UTC
This fixes it in that sox (correctly) complains that it can't set it to 8-bit.
16-bit mono still seems broken however (sox assumes the card can do this, it
doesn't look like it can.)

Comment 12 Rogelio Noriega 2000-08-02 14:26:23 UTC
2.2.17pre14->15 patch did not fix the problem. works partially in beta 5, only 
in GNOME and KDE if ran from the command line audio is very distorted. 


Comment 13 Alan Cox 2000-08-02 22:40:06 UTC
I'll try and tackle this one tomorrow Bill. If I fail then I'll send you a diff
that pulls mono support
[claiming the bug too]


Comment 14 Alan Cox 2000-08-03 22:06:12 UTC
Sent Bill several updates. It seems pretty happy here now. Please check the new
kernel
RPM when it appears an re-open the bug if its not sorted out


Comment 15 Bill Nottingham 2000-08-06 06:27:06 UTC
*** Bug 14936 has been marked as a duplicate of this bug. ***

Comment 16 Rogelio Noriega 2000-08-25 16:16:58 UTC
We are still having audio problems i810, i815 chipset.

RC2)  From the command prompt wav files will only play for  about a sec and 
then quit example yahoo.wav, splat.wav, it works fine from Xwindows. Cd audio 
works fine. Mmap sounds choppy .

Comment 17 Alan Cox 2000-08-28 19:17:57 UTC
I updated the 2.2.17pre20 code to hopefully fix the 'click' and cut off
problems. mmap is still a research project for 2.2.18


Comment 18 Bill Nottingham 2001-01-19 07:15:52 UTC
Closing this; 46xx works both in 2.2.17-8 and the current 2.4.0 sources.


Note You need to log in before you can comment on or make changes to this bug.