Bug 1374117 - Dell SC: Add secondary DSM support
Summary: Dell SC: Add secondary DSM support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 10.0 (Newton)
Assignee: Mike Burns
QA Contact: lkuchlan
URL:
Whiteboard:
: 1374118 (view as bug list)
Depends On:
Blocks: 1356451 1335593
TreeView+ depends on / blocked
 
Reported: 2016-09-08 02:17 UTC by Rajini Karthik
Modified: 2016-12-14 15:58 UTC (History)
20 users (show)

Fixed In Version: openstack-cinder-9.0.0-0.20160907194411.4057701.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1373603
Environment:
Last Closed: 2016-12-14 15:58:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 338548 None None None 2016-09-08 15:34:21 UTC

Description Rajini Karthik 2016-09-08 02:17:25 UTC
Description of problem:
Requesting a backport to mitaka
https://review.openstack.org/#/c/338548/
Adds support for a secondary DSM in case the primary becomes
unavailable.

Added thin_provisioning_support = True to the volume stats since
the Dell driver only supports thin provisioning.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rajini Karthik 2016-09-08 02:44:51 UTC
*** Bug 1374118 has been marked as a duplicate of this bug. ***

Comment 2 Karl Hastings 2016-09-12 18:26:31 UTC
The upstream change has been merged into Newton.  Is there an update on getting this backported to RHOSP9 Mitaka?

Comment 3 Rajini Karthik 2016-09-13 15:52:31 UTC
Waiting on Tom Swanson to post the backport

Comment 4 Rajini Karthik 2016-09-19 16:00:36 UTC
#1 won’t be backported. It isn’t a bugfix. So it will be available in newton

Comment 5 Karl Hastings 2016-09-19 21:15:48 UTC
Rajini,

The rule-engine set this back to OSP9.  I'm going to set it back to 10 as you requested.

If this is in error, please let me know.

-Karl

Comment 6 Eric Harney 2016-09-20 19:01:24 UTC
This bug is targeted to OSP10/Newton, where this patch has already landed, but it's blocking the js6 / OSP9 tracker.

Can you clarify what this request is for?

Thanks,
Eric

Comment 7 Rajini Karthik 2016-09-20 19:08:38 UTC
Removed blocks.

Comment 10 Mike Burns 2016-12-05 15:49:30 UTC
Rajini,  Can this be verified with the OSP 10 RC available in CDN?

Comment 11 Rajini Karthik 2016-12-05 15:50:07 UTC
Yes, will do

Comment 12 Rajini Karthik 2016-12-12 19:56:15 UTC
Tested this on RH7-RHOS-10.0-RC-2016-11-30.9.repo.
Looks good.

Comment 13 Rajini Karthik 2016-12-12 19:57:06 UTC
Mike , this can be resolved. Thanks

Comment 15 errata-xmlrpc 2016-12-14 15:58:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.