Bug 1373603 - Dell SC: Add exclude_domain_ip option
Summary: Dell SC: Add exclude_domain_ip option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: async
: 9.0 (Mitaka)
Assignee: Eric Harney
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1377435
Blocks: 1305654
TreeView+ depends on / blocked
 
Reported: 2016-09-06 17:13 UTC by Rajini Karthik
Modified: 2016-12-16 17:54 UTC (History)
16 users (show)

Fixed In Version: openstack-cinder-8.1.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1373974 1373975 1374117 1374118 (view as bug list)
Environment:
Last Closed: 2016-10-05 19:15:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2030 normal SHIPPED_LIVE openstack-cinder bug fix advisory 2016-10-05 23:11:43 UTC
OpenStack gerrit 366841 None None None 2016-09-08 15:30:53 UTC

Description Rajini Karthik 2016-09-06 17:13:53 UTC
Description of problem:
Backport this to mitaka
https://review.openstack.org/#/c/359328/
If a domain iscsi portal should NOT be returned this allows
the user to specify that. Otherwise all domains are returned.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Add multiple fault domains and exclude using exclude_domain_ip option in cinder.conf
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Eric Harney 2016-09-06 17:58:11 UTC
Can Dell provide a patch that applies to Mitaka for this change?  It's tied in with other Newton changes and is not a very straightforward backport for something that I can't test directly.

Comment 3 Rajini Karthik 2016-09-06 18:28:32 UTC
Tom Swanson(irc: swanson) is working on it. Will update the bug when he pushes the cherry pick

Comment 4 Rajini Karthik 2016-09-06 20:54:55 UTC
https://review.openstack.org/#/c/366321/ - posted

Comment 5 Rajini Karthik 2016-09-07 15:47:54 UTC
The cherry pick right one
https://review.openstack.org/#/c/366841/

Comment 6 Rajini Karthik 2016-09-15 19:33:57 UTC
This is merged in Mitaka and ready to go

Comment 7 Eric Harney 2016-09-19 17:06:42 UTC
This will be pulled in via the Cinder 8.1.1 rebase for OSP9.

Comment 10 errata-xmlrpc 2016-10-05 19:15:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2030.html

Comment 11 David Paterson 2016-11-18 20:37:02 UTC
When can we expect to get this package in OSP 9?  The latest bits still have: 
openstack-cinder-8.1.0-1.el7ost  not openstack-cinder-8.1.1-1.el7ost

Comment 12 Rajini Karthik 2016-12-16 17:53:46 UTC
This has been shipped in OSP10

Comment 13 Rajini Karthik 2016-12-16 17:54:10 UTC
This has been shipped in OSP10. Can be closed


Note You need to log in before you can comment on or make changes to this bug.