Bug 1374412 - Detach tier commit is allowed when detach tier start goes into failed state
Summary: Detach tier commit is allowed when detach tier start goes into failed state
Keywords:
Status: CLOSED DUPLICATE of bug 1375565
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1374584 1375474 1375565 1375570
TreeView+ depends on / blocked
 
Reported: 2016-09-08 15:41 UTC by krishnaram Karthick
Modified: 2016-09-30 13:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1374584 (view as bug list)
Environment:
Last Closed: 2016-09-30 13:28:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description krishnaram Karthick 2016-09-08 15:41:27 UTC
Description of problem:
Detach tier commit operation should not be allowed when detach tier start operation has gone into failed state. There might be files which are not moved from hot to cold tier when a detach tier operation fails. Allowing to commit the operation removes off the hot tier bricks, thereby making those data in hot tier inaccessible.

Version-Release number of selected component (if applicable):
rpm -qa | grep 'gluster'
glusterfs-cli-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-server-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
python-gluster-3.8.3-0.1.git2ea32d9.el7.centos.noarch
glusterfs-client-xlators-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-fuse-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
nfs-ganesha-gluster-next.20160813.2f47e8a-1.el7.centos.x86_64
glusterfs-libs-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-api-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-ganesha-3.8.3-0.1.git2ea32d9.el7.centos.x86_64

How reproducible:
Always

Steps to Reproduce:
1. create a tier vol and start detach tier operation
2. kill a brick on hot tier and restore it after a while to fail the detach tier operation
3. Try detach tier commit

Actual results:
detach tier commit is allowed

Expected results:
detach tier commit should not be allowed

Additional info:

Comment 1 Niels de Vos 2016-09-12 05:37:57 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 2 Atin Mukherjee 2016-09-30 13:28:18 UTC

*** This bug has been marked as a duplicate of bug 1375565 ***


Note You need to log in before you can comment on or make changes to this bug.