Bug 1375474 - Detach tier commit is allowed when detach tier start goes into failed state
Summary: Detach tier commit is allowed when detach tier start goes into failed state
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1374412 1374584
Blocks: 1375565 1375570
TreeView+ depends on / blocked
 
Reported: 2016-09-13 08:47 UTC by hari gowtham
Modified: 2016-10-17 09:05 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.16
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1374584
: 1375565 (view as bug list)
Environment:
Last Closed: 2016-10-17 09:05:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2016-09-13 08:47:55 UTC
+++ This bug was initially created as a clone of Bug #1374584 +++

+++ This bug was initially created as a clone of Bug #1374412 +++

Description of problem:
Detach tier commit operation should not be allowed when detach tier start operation has gone into failed state. There might be files which are not moved from hot to cold tier when a detach tier operation fails. Allowing to commit the operation removes off the hot tier bricks, thereby making those data in hot tier inaccessible.

Version-Release number of selected component (if applicable):
rpm -qa | grep 'gluster'
glusterfs-cli-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-server-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
python-gluster-3.8.3-0.1.git2ea32d9.el7.centos.noarch
glusterfs-client-xlators-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-fuse-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
nfs-ganesha-gluster-next.20160813.2f47e8a-1.el7.centos.x86_64
glusterfs-libs-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-api-3.8.3-0.1.git2ea32d9.el7.centos.x86_64
glusterfs-ganesha-3.8.3-0.1.git2ea32d9.el7.centos.x86_64

How reproducible:
Always

Steps to Reproduce:
1. create a tier vol and start detach tier operation
2. kill a brick on hot tier and restore it after a while to fail the detach tier operation
3. Try detach tier commit

Actual results:
detach tier commit is allowed

Expected results:
detach tier commit should not be allowed

Additional info:

--- Additional comment from Worker Ant on 2016-09-09 03:02:31 EDT ---

REVIEW: http://review.gluster.org/15438 (Tier: failing detach commit on detach failure and in-progress) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-09-09 05:24:31 EDT ---

REVIEW: http://review.gluster.org/15438 (Tier: failing detach commit on detach failure and in-progress) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2016-09-12 09:27:36 EDT ---

COMMIT: http://review.gluster.org/15438 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 1afa0bd91fd23b5131ccc1cceb814a061ac99096
Author: hari gowtham <hgowtham@redhat.com>
Date:   Fri Sep 9 12:26:52 2016 +0530

    Tier: failing detach commit on detach failure and in-progress
    
    PROBLEM: if detach status has failed or if it remains in progress
    we allow detach commit to happen. only detach force should
    be allowed.
    
    FIX: check the detach status for failure or inprogress and disallow
    with the apt error message.
    
    Change-Id: Ib97d540fec67717bb55c18d133187c665cf69ef1
    BUG: 1374584
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/15438
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 1 Worker Ant 2016-09-13 12:05:15 UTC
REVIEW: http://review.gluster.org/15491 (Tier: failing detach commit on detach failure and in-progress) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Worker Ant 2016-09-13 19:24:31 UTC
COMMIT: http://review.gluster.org/15491 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit eaf9c1b314f1abf0ab4e3ddec37bf24490f4d716
Author: hari gowtham <hgowtham@redhat.com>
Date:   Fri Sep 9 12:26:52 2016 +0530

    Tier: failing detach commit on detach failure and in-progress
    
            back-port of: http://review.gluster.org/#/c/15438/
    
    PROBLEM: if detach status has failed or if it remains in progress
    we allow detach commit to happen. only detach force should
    be allowed.
    
    FIX: check the detach status for failure or inprogress and disallow
    with the apt error message.
    
    >Change-Id: Ib97d540fec67717bb55c18d133187c665cf69ef1
    >BUG: 1374584
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/15438
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I932b1074de277361fe7c3fe247d799f772cf4658
    BUG: 1375474
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/15491
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2016-10-17 09:05:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.16, please open a new bug report.

glusterfs-3.7.16 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-October/051187.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.