Bug 1378010 - RHVH 40: The help info show as RHEL during anaconda interactive installation.
Summary: RHVH 40: The help info show as RHEL during anaconda interactive installation.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: pre-dev-freeze
: 7.4
Assignee: Martin Kolman
QA Contact: Release Test Team
URL:
Whiteboard:
: 1528157 (view as bug list)
Depends On: 1425885
Blocks: ovirt-node-ng-platform ovirt-node-ng-43-el76-platform 1499875
TreeView+ depends on / blocked
 
Reported: 2016-09-21 09:57 UTC by cshao
Modified: 2018-04-10 08:47 UTC (History)
9 users (show)

Fixed In Version: anaconda-21.48.22.126-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1499875 (view as bug list)
Environment:
Last Closed: 2018-04-10 08:45:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
help-info1 (141.35 KB, image/png)
2016-09-21 09:57 UTC, cshao
no flags Details
help-info2 (150.45 KB, image/png)
2016-09-21 09:58 UTC, cshao
no flags Details
still can reproduce (139.79 KB, image/png)
2018-02-16 13:10 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0671 None None None 2018-04-10 08:47:04 UTC

Description cshao 2016-09-21 09:57:50 UTC
Created attachment 1203201 [details]
help-info1

Description of problem:
RHVH 40: The help info show as RHEL during anaconda interactive installation, it need SYNC to RHVH.

Version-Release number of selected component (if applicable):
RHVH-4.0-20160919.1-RHVH-x86_64-dvd1.iso
redhat-virtualization-host-4.0-20160919.0
imgbased-0.8.5-0.1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Anaconda interactive installation RHVH via ISO with default ks.
2. Click help button.
3. Focus on the pop-up info of help.

Actual results:
The help info show as RHEL during anaconda interactive installation,

Expected results:
The help info show as RHEV during anaconda interactive installation,

Additional info:

Comment 1 cshao 2016-09-21 09:58:40 UTC
Created attachment 1203202 [details]
help-info2

Comment 3 Martin Kolman 2016-09-22 12:53:11 UTC
(In reply to shaochen from comment #0)
> Created attachment 1203201 [details]
> help-info1
> 
> Description of problem:
> RHVH 40: The help info show as RHEL during anaconda interactive
> installation, it need SYNC to RHVH.
> 
> Version-Release number of selected component (if applicable):
> RHVH-4.0-20160919.1-RHVH-x86_64-dvd1.iso
> redhat-virtualization-host-4.0-20160919.0
> imgbased-0.8.5-0.1.el7ev.noarch
> 
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Anaconda interactive installation RHVH via ISO with default ks.
> 2. Click help button.
> 3. Focus on the pop-up info of help.
> 
> Actual results:
> The help info show as RHEL during anaconda interactive installation,
> 
> Expected results:
> The help info show as RHEV during anaconda interactive installation,
> 
> Additional info:

So if I understand this correctly, this is a branding issue - you want the OS being installed to be consistently called RHEV in the help screens, right ?

The help content shown in the help screens is generated from the RHEL7 Installation Guide, so it should be probably consulted with the documentation people - adding Clayton, the Installation Guide maintainer, to CC.

BTW, do you also use the web-version of the Installation Guide for RHEV ? It should have basically the same branding issues & possibly also the same fix.

Comment 4 cshao 2016-09-23 03:57:43 UTC
(In reply to Martin Kolman from comment #3)
> (In reply to shaochen from comment #0)
> > Created attachment 1203201 [details]
> > help-info1
> > 
> > Description of problem:
> > RHVH 40: The help info show as RHEL during anaconda interactive
> > installation, it need SYNC to RHVH.
> > 
> > Version-Release number of selected component (if applicable):
> > RHVH-4.0-20160919.1-RHVH-x86_64-dvd1.iso
> > redhat-virtualization-host-4.0-20160919.0
> > imgbased-0.8.5-0.1.el7ev.noarch
> > 
> > 
> > How reproducible:
> > 100%
> > 
> > Steps to Reproduce:
> > 1. Anaconda interactive installation RHVH via ISO with default ks.
> > 2. Click help button.
> > 3. Focus on the pop-up info of help.
> > 
> > Actual results:
> > The help info show as RHEL during anaconda interactive installation,
> > 
> > Expected results:
> > The help info show as RHEV during anaconda interactive installation,
> > 
> > Additional info:
> 
> So if I understand this correctly, this is a branding issue - you want the
> OS being installed to be consistently called RHEV in the help screens, right
> ?
> 
Yes, you are right. 
And this is branding issue.

> The help content shown in the help screens is generated from the RHEL7
> Installation Guide, so it should be probably consulted with the
> documentation people - adding Clayton, the Installation Guide maintainer, to
> CC.
> 
> BTW, do you also use the web-version of the Installation Guide for RHEV ?
Yes, but our web version is guide for documentation/en/red-hat-virtualization/4.0/paged/installation-guide/, seem this is no help info be mentioned in this guide.

> should have basically the same branding issues & possibly also the same fix.

Comment 5 Petr Bokoc 2017-02-22 16:47:04 UTC
Hello, I'm one of the people working on the RHEL Installation Guide.

This is going to require changes on our side. Right now, when you're building Anaconda, it pulls help content from the RHEL Installation Guide repo, and we're not equipped to easily change the product name (plus we didn't know we needed to), so it keeps referencing RHEL.

I opened a bug for the RHEL Installation Guide to track the changes required to make this work: https://bugzilla.redhat.com/show_bug.cgi?id=1425885

Ideally the end result will be that we'll be able to build help content for either RHEL or RHEV, with each referencing the correct product, and the RHEV version should have references to custom partitioning removed since that's going to be restricted in RHEV's anaconda (and current documentation strongly discourages using custom partitioning as well) - as per https://bugzilla.redhat.com/show_bug.cgi?id=1412151

We'd like to have this done by the time RHEL 7.4 comes out. We're pretty short on resources already, but we'll be treating this as high priority. If you have any questions, let me know.

Comment 7 Martin Kolman 2017-08-17 12:49:08 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1154

Comment 10 Yuval Turgeman 2018-01-15 10:31:10 UTC
*** Bug 1528157 has been marked as a duplicate of this bug. ***

Comment 13 cshao 2018-02-16 13:10:19 UTC
Created attachment 1397007 [details]
still can reproduce

Comment 18 Jan Stodola 2018-02-22 08:57:20 UTC
Thank you for checking.
Moving to VERIFIED based on comment 17.

Comment 21 errata-xmlrpc 2018-04-10 08:45:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0671


Note You need to log in before you can comment on or make changes to this bug.