Bug 1379285 - gfapi: Fix fd ref leaks
Summary: gfapi: Fix fd ref leaks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1379707 1379708 1379710 1379924
TreeView+ depends on / blocked
 
Reported: 2016-09-26 09:31 UTC by Soumya Koduri
Modified: 2017-03-06 17:27 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1379707 1379708 1379710 1379924 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:27:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Soumya Koduri 2016-09-26 09:31:26 UTC
Description of problem:

From the code inspection, have observed that there are fd ref leaks for few fd-based gfapi fops. 'glfs_resolve_fd' returns a fd (either existing or migrated) with an extra ref taken. This needs to be unref'ed at the end of the operation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-09-26 09:35:39 UTC
REVIEW: http://review.gluster.org/15573 (gfapi: Fix few fd ref leaks) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 2 Worker Ant 2016-09-27 06:43:38 UTC
COMMIT: http://review.gluster.org/15573 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit d27cffab670858d7812bbb458a0833303d009b3b
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Mon Sep 26 14:54:27 2016 +0530

    gfapi: Fix few fd ref leaks
    
    From the code inspection, have observed that there are fd ref
    leaks for few fd-based gfapi fops. 'glfs_resolve_fd' returns
    a fd (either existing or migrated) with an extra ref taken.
    This needs to be unref'ed at the end of the operation.
    
    Change-Id: Id63394e3e7deafb0c8b06444f2ae847248b126db
    BUG: 1379285
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/15573
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Shyamsundar 2017-03-06 17:27:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.