Bug 1379708 - gfapi: Fix fd ref leaks
Summary: gfapi: Fix fd ref leaks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.8
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1379285 1379924
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-27 13:33 UTC by Niels de Vos
Modified: 2016-10-20 14:04 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1379285
Environment:
Last Closed: 2016-10-20 14:04:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-09-27 13:33:51 UTC
+++ This bug was initially created as a clone of Bug #1379285 +++

Description of problem:

From the code inspection, have observed that there are fd ref leaks for few fd-based gfapi fops. 'glfs_resolve_fd' returns a fd (either existing or migrated) with an extra ref taken. This needs to be unref'ed at the end of the operation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-09-26 11:35:39 CEST ---

REVIEW: http://review.gluster.org/15573 (gfapi: Fix few fd ref leaks) posted (#1) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Worker Ant on 2016-09-27 08:43:38 CEST ---

COMMIT: http://review.gluster.org/15573 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit d27cffab670858d7812bbb458a0833303d009b3b
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Mon Sep 26 14:54:27 2016 +0530

    gfapi: Fix few fd ref leaks
    
    From the code inspection, have observed that there are fd ref
    leaks for few fd-based gfapi fops. 'glfs_resolve_fd' returns
    a fd (either existing or migrated) with an extra ref taken.
    This needs to be unref'ed at the end of the operation.
    
    Change-Id: Id63394e3e7deafb0c8b06444f2ae847248b126db
    BUG: 1379285
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/15573
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2016-09-28 06:38:59 UTC
REVIEW: http://review.gluster.org/15585 (gfapi: Fix few fd ref leaks) posted (#1) for review on release-3.8 by soumya k (skoduri@redhat.com)

Comment 2 Worker Ant 2016-09-30 12:45:00 UTC
COMMIT: http://review.gluster.org/15585 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 7a50690e8939d1f806556ece1bad9fc2a81c3b80
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Mon Sep 26 14:54:27 2016 +0530

    gfapi: Fix few fd ref leaks
    
    From the code inspection, have observed that there are fd ref
    leaks for few fd-based gfapi fops. 'glfs_resolve_fd' returns
    a fd (either existing or migrated) with an extra ref taken.
    This needs to be unref'ed at the end of the operation.
    
    Mainline reference:
    > Change-Id: Id63394e3e7deafb0c8b06444f2ae847248b126db
    > BUG: 1379285
    > Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    > Reviewed-on: http://review.gluster.org/15573
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    (cherry picked from commit d27cffab670858d7812bbb458a0833303d009b3b)
    
    Change-Id: I0919abbddb618d08aaf77b2ce1173eec18b382f1
    BUG: 1379708
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/15585
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2016-10-20 14:04:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.5, please open a new bug report.

glusterfs-3.8.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-October/000061.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.