Bug 138055 - Installer GUI crashes (i810 driver in xorg)
Installer GUI crashes (i810 driver in xorg)
Status: CLOSED DUPLICATE of bug 132267
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 01:39 EST by Srihari Vijayaraghavan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg-crash-screen-shot (1.65 KB, image/jpeg)
2004-11-04 01:45 EST, Srihari Vijayaraghavan
no flags Details
X.log (31.36 KB, text/plain)
2004-11-04 01:47 EST, Srihari Vijayaraghavan
no flags Details
FC3-Xorg-crash-screen-shot-1 (corrupted screen). (10.80 KB, text/plain)
2004-11-09 19:11 EST, Srihari Vijayaraghavan
no flags Details

  None (edit)
Description Srihari Vijayaraghavan 2004-11-04 01:39:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.3)
Gecko/20041026 Firefox/1.0RC1

Description of problem:
The Installer GUI crashes and completely locks up. Refer to the
screen-shot. It is reproduable across few machines.

Version-Release number of selected component (if applicable):
FC3 RC5

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot through the instllation CD 1
2. Let the GUI Installation start

    

Actual Results:  Locks up completely.

Expected Results:  It may not lock up.

Additional info:

The video card is an integrated i810 on IBM NetVista P-III desktops
and in the BIOS I set to maximum possible video RAM of 1 MB.

lspci information:
00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 02) (prog-if 00 [VGA])
	Subsystem: IBM: Unknown device 01e2
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 0
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Region 1: Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

(Other information can be provided on request.)

If I let it start the GUI installer then it hangs most of the time
(across few identical machines), but OTOH, if I press ctrl+alt+f2
repeatedly while it is trying to load GUI Installer, then it survives.
And I can switch back to GUI installer and continue the installation.

I have a serial console (BTW it is great you have a serial console in
Installation kernel) and I do not see any BUG, OOPS or panic messages.
While it responds to sysrq, it prints nothing for showMem, showPc and
showTasks.

I have attached the screen shot of the crash and the X log file (of
the working setup using my work-around trick: repeatedly pressing
ctrl+alt+f2)

Thank you.
Hari

PS: Oh, these machines work great under Fedora Core 2.
Comment 1 Srihari Vijayaraghavan 2004-11-04 01:45:14 EST
Created attachment 106152 [details]
Xorg-crash-screen-shot
Comment 2 Srihari Vijayaraghavan 2004-11-04 01:47:07 EST
Created attachment 106153 [details]
X.log
Comment 3 Srihari Vijayaraghavan 2004-11-09 18:07:08 EST
I managed to install FC3. But I see corrupted screen (in the initial
setup screen, GDM logon screen etc..). In other words, the problem
still persists in FC3.
Comment 4 Srihari Vijayaraghavan 2004-11-09 18:42:33 EST
The display is very bad under X. In various applications (Open Office,
Firefox etc..), the screen is completely corrupted and is not really
useable. Please refer to the photograph
(FC3-Xorg-crash-screen-shot-1.jpg).

(If there is a work around or fix available, please let me know, and I
shall be glad to test things out. I would love to have a good quality
display.)

Thank you.
Hari
Comment 5 Srihari Vijayaraghavan 2004-11-09 19:11:26 EST
Created attachment 106383 [details]
FC3-Xorg-crash-screen-shot-1 (corrupted screen).

The corrupted Open Office Calc and Firefox windows are shown there.
Comment 6 nathan black 2004-11-10 16:07:30 EST
See bugs #133010, #132267 they may be related to the x driver issues
on 810, 815 and 845 cards.
Comment 7 Dr. Tilmann Bubeck 2004-11-10 18:10:42 EST
I can confirm the bug on my HP e-pc. It looks exactly the same and it
locks up, too.
Any more info on request.
Comment 8 Dr. Tilmann Bubeck 2004-11-10 18:15:56 EST
This could be related to bugzilla on freedesktop.org:

https://freedesktop.org/bugzilla/show_bug.cgi?id=1455

Comment 9 Manfred Georg 2004-11-11 20:46:05 EST
This is not restricted to installer process.  In fact I didn't notice
it until I had installed the system (using text install).

More info in bug 138948.
Comment 10 Mike A. Harris 2004-11-12 12:39:55 EST

*** This bug has been marked as a duplicate of 132267 ***
Comment 11 Red Hat Bugzilla 2006-02-21 14:06:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.