Bug 138441 - libidn-devel missing as build requirement
libidn-devel missing as build requirement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
: 142395 146449 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 05:36 EST by Philipp Hügelmeyer
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 7.12.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 12:45:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Hügelmeyer 2004-11-09 05:36:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041109 Firefox/1.0

Description of problem:
php does not build from source, libidn-devel is msising as a build
requirement. rpmbuild -bb php.spec fails in the configure script.



Version-Release number of selected component (if applicable):
php-4.3.9-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -i php-4.3.9-3.src.rpm 
2. cd redhat/SPECS
3. rpmbuild -bb php.spec
    

Additional info:
Comment 1 Joe Orton 2004-11-09 06:32:27 EST
Looks like curl-devel should Require: libidn-devel
Comment 2 Robert Scheck 2004-11-09 06:36:32 EST
This build requirement to libidn-devel should be added to curl-devel, 
not to php(-devel). Every package linking against curl and/or using 
curl-devel can possibly fall into this problem and it would be the 
worst case to add libidn-devel to every package requiring curl-devel.

This problem was introduced with bug #134595, where curl got IDN 
support enabled. After moving this bug, it also should be marked as 
EasyFix (Joe, you caused a midair collision *g*).
Comment 3 Robert Scheck 2004-11-19 17:58:03 EST
Adrian, this fix didn't reach Rawhide, yet - why?!
Comment 4 Eido Inoue 2004-11-22 04:58:11 EST
comment 3: you're right-- it didn't get pushed out from internal
(accident). I'm going to consolidate it with one more important patch
and re-push later this week-- as this bug isn't high enough priority
to need two pushes in one week (it only affects people re-building
from the src)
Comment 5 Joe Orton 2004-12-09 10:19:10 EST
*** Bug 142395 has been marked as a duplicate of this bug. ***
Comment 6 Joe Orton 2005-01-28 08:18:05 EST
*** Bug 146449 has been marked as a duplicate of this bug. ***
Comment 7 Joe Orton 2005-01-28 08:20:10 EST
Adrian if there's any other motivation to push a curl update for FC3 please
include this fix since lots of people are hitting it.

Note You need to log in before you can comment on or make changes to this bug.