Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1384575 - gnome-shell overview rendering glitch
Summary: gnome-shell overview rendering glitch
Keywords:
Status: CLOSED DUPLICATE of bug 1384440
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-13 15:05 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2016-10-13 20:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-13 20:34:41 UTC
Type: Bug


Attachments (Terms of Use)
screenshot with the visual glitch (283.48 KB, image/png)
2016-10-13 15:05 UTC, Zbigniew Jędrzejewski-Szmek
no flags Details

Description Zbigniew Jędrzejewski-Szmek 2016-10-13 15:05:19 UTC
Created attachment 1210174 [details]
screenshot with the visual glitch

Description of problem:
As part of the wayland test day, I started a virt-manager VM from the testday iso, with virtio graphics. In the activities overview, after dragging an icon from the dash to an unused workspace, the new application is started in the current workspace, not the dragged-to one, and the overview becomes confused, see attached screenshot. A new empty workspace is created at the end, and then it goes away after a while.

Version-Release number of selected component (if applicable):
gnome-shell-3.22.1-1.fc25.x86_64

How reproducible:
Starting the application in the wrong workspace happens every time. The visual glitch only once.

Comment 1 Zbigniew Jędrzejewski-Szmek 2016-10-13 15:12:04 UTC
OK, I know how to reproduce the glitch reliably:
1. start with an empty workspace
2. drag Evolution icon onto some workspace on the dock
3. move the mouse to the middle of screen, where the newly created window appears. The border for the window is off like in the screenshot.

Comment 2 Adam Williamson 2016-10-13 20:34:41 UTC
We already have separate reports for the workspace issue and the border issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1384440 (workspace issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1384616 (border issue)

thanks for reporting!

*** This bug has been marked as a duplicate of bug 1384440 ***


Note You need to log in before you can comment on or make changes to this bug.