Bug 138591 - AUX for Canna LE to accept ESC key
AUX for Canna LE to accept ESC key
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: FutureFeature, i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-11-09 21:19 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 20:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-11-09 21:19:35 EST
Description of problem:
Further to bug 135039, I think IIIMF server needs to process the ESC
key so that aux window can be quit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=ja_JP.UTF-8 gedit
2.Press "HOME" to bring up the aux window 
3.Press "ESC"
  
Actual results:
Nothing happens

Expected results:
The aux window should quit

Additional info:
Comment 1 Akira TAGOH 2004-11-10 00:09:15 EST
Well, since the aux object depends on each implementation, it's Canna
LE's specific problem in this case, but not the server.
Comment 2 Akira TAGOH 2004-11-11 07:54:29 EST
should be fixed in 12.1-7. please note that you have to kill auxmenu
process first due to Bug#132508.
Comment 3 Lawrence Lim 2004-11-14 23:07:31 EST
Confirmed fixed in im-sdk-12.1-7. 

I have a question though, killing com.OpenI18N.leif.CannaLE.menu
causes auxmenu[defunct]. Is this a normal behoviour?
Comment 4 Akira TAGOH 2004-11-15 00:47:12 EST
Hmm, not really. it works for me, though. can you reproduce it anyway?
Comment 5 Lawrence Lim 2004-11-15 05:08:35 EST
- Before activaing CannaLE

[root@hunter ~]# ps -auxwww |grep com
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
root      3576  0.0  0.1  5920  776 pts/1    S+   20:06   0:00 grep com

- After activating CannLE

[root@hunter ~]# ps -auxwww |grep com
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
root      3577  0.1  0.5 12276 3912 ?        S    20:06   0:00
com.OpenI18N.leif.CannaLE.menu

- kill the menu process and look at the process again

[root@hunter ~]# kill -9 3577
[root@hunter ~]# ps -auxwww |grep com
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
root      3583  0.0  0.1  6280  780 pts/1    S+   20:07   0:00 grep com

- finally, the auxmenu that will not die
[root@hunter ~]# ps -auxwww |grep auxmenu
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
root      3577  0.0  0.0     0    0 ?        Z    20:06   0:00 [auxmenu] <defunct>
Comment 6 Akira TAGOH 2004-11-15 07:42:28 EST
Well, you mean you did kill auxmenu without exiting the applications,
right? I can reproduce it then.  However, it's the normal behavior
right now, because it wouldn't expects that the aux object is
destroyed during running the applications. so auxmenu is just waiting
until the parent process catches the exit status.  Doesn't it
disappear when you kill the applications as well?
Comment 7 Lawrence Lim 2004-11-15 20:00:29 EST
Thanks for the information. I totally understand the process now. :)

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.