Bug 1390020 - [abiword] text body in abiword turns black all the time, e.g. when losing focus
Summary: [abiword] text body in abiword turns black all the time, e.g. when losing focus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 22:27 UTC by Joachim Frieben
Modified: 2016-12-20 17:20 UTC (History)
9 users (show)

Fixed In Version: abiword-3.0.2-3.fc25 abiword-3.0.2-3.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-20 06:22:37 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of new abiword window (36.38 KB, image/png)
2016-10-30 22:27 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2016-10-30 22:27:17 UTC
Created attachment 1215633 [details]
Screenshot of new abiword window

Description of problem:
When launching abiword using the X11 backend in order to avoid bug 1288847, then the text body is rendered black. It turns white when selecting the text-body area with the mouse. However, as soon as focus moves to a different window, it turns black again. The correct background colour is only restored after selecting the text-body area with the mouse once again.

Version-Release number of selected component (if applicable):
xorg-x11-server-1.19.0-0.3.20161026.fc25

How reproducible:
Always

Steps to Reproduce:
1. Launch abiword.

Actual results:
Text-body area is black.

Expected results:
Text-body area is white.

Additional info:
Issue is absent under Fedora 24.

Comment 1 Joachim Frieben 2016-11-30 15:14:23 UTC
After updating to abiword-3.0.2-2.fc25, the text body turns out to be constantly black in a GNOME on Wayland session, even worse than in a GNOME on Xorg session.

Comment 2 Joachim Frieben 2016-11-30 15:19:46 UTC
*** Bug 1390367 has been marked as a duplicate of this bug. ***

Comment 3 Joachim Frieben 2016-11-30 15:21:06 UTC
*** Bug 1398773 has been marked as a duplicate of this bug. ***

Comment 4 David H. Gutteridge 2016-12-01 21:24:14 UTC
For me, abiword-3.0.2-2.fc25 is worse than abiword-3.0.1-12.fc25 on Gnome under Xorg. (But as far as Wayland is concerned, both versions are completely unusable for me, because the older version would crash on start every time, whereas the new one at least runs, but the text display is consistently black.)

Comment 5 R P Herrold 2016-12-02 14:32:51 UTC
David -- I see you posted non=positive karma ('worse than before') ... but dont indicate WHAT is not working for you with abiword-3.0.2-2.fc25

could you please be more specific in a new bug under that new release?

Comment 6 David H. Gutteridge 2016-12-02 22:39:17 UTC
(In reply to R P Herrold from comment #5)
> David -- I see you posted non=positive karma ('worse than before') ... but
> dont indicate WHAT is not working for you with abiword-3.0.2-2.fc25
> 
> could you please be more specific in a new bug under that new release?

Sorry, I'd assumed it was implicit my comment was germane to this bug, i.e. I'm seeing the same visual effects, just more pronounced than before. In abiword-3.0.1-12.fc25 I see the same issue as the original reporter, as he's already described. In abiword-3.0.2-2.fc25 under Xorg the text area is completely black and flickers constantly. There's no way to ever read anything, it's unusable.

I'm not inclined to open a new bug because to me this is related to this existing report; it's presumably the same underlying cause. And there's still at least one other one bug report open that seems a duplicate of this one (https://bugzilla.redhat.com/show_bug.cgi?id=1287835).

Comment 7 Hubert Figuiere 2016-12-08 02:24:31 UTC
I think what you are seeing is bug http://bugzilla.abisource.com/show_bug.cgi?id=13815 which was just fixed upstream. It was only when running Gtk 3.22 which Fedora 25 has.

It will be part of 3.0.3.

Comment 8 Hubert Figuiere 2016-12-08 02:57:35 UTC
You can grab the patch on the github mirror at:

https://github.com/AbiWord/abiword/commit/cec2fda355b67b5b814a803c5ed128c425cbb030

Comment 9 Fedora Update System 2016-12-08 04:27:50 UTC
abiword-3.0.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab

Comment 10 Fedora Update System 2016-12-08 04:29:20 UTC
abiword-3.0.2-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57

Comment 11 Hubert Figuiere 2016-12-08 04:33:43 UTC
This build include the patch from upstream. Please let us know if that works for you.

Comment 12 David H. Gutteridge 2016-12-08 05:43:51 UTC
It resolves this for me under both Wayland and Xorg. Abiword's now usable in both on Fedora 25. Thanks!

(Under Wayland, the caret isn't visible, but I realize this is a known issue tracked in http://bugzilla.abisource.com/show_bug.cgi?id=13767 already. I mention this for any end users thinking of filing a bug.)

Comment 13 Fedora Update System 2016-12-08 19:23:54 UTC
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ffbf1200ab

Comment 14 Fedora Update System 2016-12-08 19:25:51 UTC
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ca183cdc57

Comment 15 Fedora Update System 2016-12-20 06:22:37 UTC
abiword-3.0.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-12-20 17:20:46 UTC
abiword-3.0.2-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.