Bug 139116 - gamin doesn't refresh
gamin doesn't refresh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 18:31 EST by Isaac Newton
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.0.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 08:07:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Isaac Newton 2004-11-12 18:31:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
nothing appears in nautilus after extract my archive with file-roller

Version-Release number of selected component (if applicable):
gamin-0.0.15-1

How reproducible:
Always

Steps to Reproduce:
1.extract an archive(tar.gz) with file-roller
2.
3.
    

Additional info:
Comment 1 Mike Sowka 2004-11-15 22:53:46 EST
I concur... and to add, I belive the problem may have started after I
switched my nautilus home dir to my ~/ via the desktop_is_home_dir
gconf key in the nautilus gconf settings.

Please advise of fix/workaround...

Thanx
Comment 2 Luke Simon 2004-11-23 16:34:42 EST
This is the same as the bug 140456
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=140456
Comment 3 Marius Andreiana 2004-12-07 07:22:13 EST
which is duplicate of bug 130859
Comment 4 William Lovaton 2004-12-21 09:42:25 EST
As a workaround you can click on your desktop and hit Ctrl+R to
refresh the state.  That should make the trick.

Another related problem show up in the Computer place when you mount a
filesystem.  It refreshes only when you unmount but not when you
mount.  For example if the device is unmounted and you right-click the
icon and click on "mount" it won't refresh.  When you right-click
again on the icon it still says "mount".  When you click on it an
error message show up saying that the device is already mounted.

I think this is something related to inotify/gamin.
Comment 5 Daniel Veillard 2004-12-21 10:52:36 EST
It cannot be inotify, we don't ship kernels with inotify !
Please try with the latest version of gamin (0.0.19) and report,

Daniel
Comment 6 Isaac Newton 2004-12-22 05:38:41 EST
im upgrade to gamin-0.0.19-1 from updates-testing but it doesn´t fix
the bug 
Comment 7 William Lovaton 2004-12-22 11:48:23 EST
Daniel: upss. I have been reading lots of development news lately.
inotify is in 2.6.10-RC2 I think.  But gamin can work (and will work)
with inotify... right?

I updated to gamin-0.0.19-1 as you suggested but this doesn't fix the
problem.

I noticed something new though, with the old (0.0.17) and with the new
version of gamin.  When you use file-roller and drag a file and drop
it into nautilus it will work, the new file show up in nautilus
instantly.  Now, when you select the file in file-roller and click on
the "Extract" button in the tool bar and select the desired folder, it
won't show up.  It will appear only after you refresh the nautilus
view.  This happens whether it is the desktop or a reagular folder.

The funny thing is that after extracting it will appear when I browse
that directory via the file chooser in file-roller (or the file
chooser from any gnome app).

And even more courious is that nautilus won't refresh the view when
browsing it with the navigational mode.  So there are two views of the
same folder, one with spatial and one with navigational.  Just Ctrl+R
in one of them and then the file show up in both.

Could any of the bug commenters try this and confirm what I am seeing?
 May be this is a file-roller bug or something... However gamin should
see the event anyway.
Comment 8 Don Hardaway 2005-01-16 10:33:45 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143679

this bug is the same as 143679.
Comment 9 Christopher Beland 2005-02-20 10:49:45 EST
The release notes for gamin-0.0.24-1.FC3 say that this bug should be fixed in
this version.  I was having similar symptoms, as reported in Bug 147925, which
seem to have gotten better.
Comment 10 Daniel Veillard 2005-03-12 13:57:53 EST
I think this is fixed in the current release 0.0.25,

Daniel

Note You need to log in before you can comment on or make changes to this bug.