Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 140456 - recently saved file does appear on the desktop
recently saved file does appear on the desktop
Status: CLOSED DUPLICATE of bug 130859
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 140642 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 17:22 EST by Will McCammon
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will McCammon 2004-11-22 17:22:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
recently saved file does not appear on the desktop until a subsequent
file is saved on the desktop.  the second file will not appear until a
third file is saved to the desktop.  the third file will not appear
until a fourth file is saved on the desktop.  and so on...

Version-Release number of selected component (if applicable):
2.8.1 release 4

How reproducible:
Always

Steps to Reproduce:
1. save a file in ~/Desktop using firefox
2. go to the desktop.  the file does not appear.
3. save a file in ~/Desktop using gedit
4. go to the desktop.  the file saved by firefox appears but the file
saved by gedit does not.
5. save a file in ~/Desktop using openoffice writer.
6. go to the desktop.  the file saved by gedit appears but the file
saved by openoffice writer does not.
7. open terminal session.
8. ls ~/Desktop.  all files are present including the one saved by
openoffice writer
    

Expected Results:  files should appear on the desktop shortly after
saved in ~/Desktop.

Additional info:

changing desktops in the pager does not help.  opening a new nautilus
window does not help.

logging out and back in again refreshes the desktop so that all files
are seen including the latest saved file.
Comment 1 Luke Simon 2004-11-23 16:30:59 EST
I have the same problem.  It appears to have something to do with
setting Nautilus to "browse" mode as opposed to "spatial" mode.  I
hate how spatial mode is crammed down our throats.  So "always browse"
is an option, but it is for some reason slower and buggier than
spatial mode?

It is really annoying when using Firefox with the default download
directory set as your desktop.  You save their because it is really
easy to directly get to your current files.  However, since they don't
show up until a forced refresh, it is a real pain!

Can somebody please confirm that this bug is in fact caused by browser
mode?
Comment 2 Luke Simon 2004-11-23 16:35:44 EST
This is the same as bug 139116.
Comment 3 Richard Torkar 2004-11-23 17:24:54 EST
Are you sure?

If I do (in FC3) like this I can reproduce it:

1. Open a term window
2. cd ~
3. touch file1.txt
4. mv file1.txt Desktop/

I don't see file1.txt on my desktop or if I double-click my home icon
-> desktop it doesn't show up there but still it exists there
according to a simple ls ~/Desktop 
Comment 4 Luke Simon 2004-11-23 17:52:57 EST
Ok, I was wrong.  The bug also occurs in spatial mode, when using
Richard's method.  For some reason I didn't have the problem with
Firefox and spatial mode.

This bug is really annoying!
Comment 5 Sitsofe Wheeler 2004-11-24 18:59:37 EST
This sounds a lot like bug 140642
Comment 6 Need Real Name 2004-11-30 09:41:57 EST
*** Bug 140642 has been marked as a duplicate of this bug. ***
Comment 7 William Lovaton 2004-12-01 08:31:19 EST
A little workaround: Refresh your desktop after saving files in it. 
Just click the background of the desktop and press Ctrol+R.  Though
annoying it is easy to do.
Comment 8 Luke Simon 2004-12-01 13:58:19 EST
How was this bug not noticed?  I am surprised something so basic and
fundamental to a desktop would make its way into a full release
(Fedora Core 3).  Are there people that do not that this problem,
aside from KDE users?  Gnome is the default desktop, so I was
surprised to see such a obvious bug.
Comment 9 Alexander Larsson 2004-12-03 04:47:48 EST
This is likely a gamin bug. In fact i think its a dup of bug 130859.

*** This bug has been marked as a duplicate of 130859 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:07:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.