Bug 1394719 - libgfapi core dumps
Summary: libgfapi core dumps
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: rjoseph
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1387558
Blocks: 1397662 1397663 1397664
TreeView+ depends on / blocked
 
Reported: 2016-11-14 10:08 UTC by rjoseph
Modified: 2017-03-06 17:33 UTC (History)
13 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1387558
: 1397662 1397663 1397664 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:33:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-11-14 10:14:08 UTC
REVIEW: http://review.gluster.org/15842 (gfapi: mempool is added to ctx pool list without lock) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Worker Ant 2016-11-14 10:15:47 UTC
REVIEW: http://review.gluster.org/15842 (libglusterfs: mempool is added to ctx pool list without lock) posted (#2) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 3 Worker Ant 2016-11-15 05:31:22 UTC
REVIEW: http://review.gluster.org/15842 (libglusterfs:Now mempool is added to ctx pool list under a lock) posted (#3) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 4 Worker Ant 2016-11-22 12:45:38 UTC
COMMIT: http://review.gluster.org/15842 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 277008a3a8583ef10cec9e4182960792e56c5c10
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Mon Nov 14 15:40:32 2016 +0530

    libglusterfs:Now mempool is added to ctx pool list under a lock
    
    mempool is added to ctx pool list without any lock. This can cause undefined
    behaviour in case of multithreaded environment.
    
    Fix: modify the list only under ctx->lock
    
    Change-Id: I7bdbb3db48a899bb0e41427e149b13c0facaedba
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    BUG: 1394719
    Reviewed-on: http://review.gluster.org/15842
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 5 Shyamsundar 2017-03-06 17:33:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.