Bug 1397664 - libgfapi core dumps
Summary: libgfapi core dumps
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: rjoseph
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1387558 1394719
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 06:04 UTC by rjoseph
Modified: 2017-03-08 10:19 UTC (History)
14 users (show)

Fixed In Version: glusterfs-3.9.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1394719
Environment:
Last Closed: 2017-03-08 10:19:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-11-23 06:07:19 UTC
REVIEW: http://review.gluster.org/15908 (libglusterfs:Now mempool is added to ctx pool list under a lock) posted (#1) for review on release-3.9 by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Worker Ant 2016-11-28 09:10:42 UTC
COMMIT: http://review.gluster.org/15908 committed in release-3.9 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 1b003694f24d82a946e0584213ccf399ba923d58
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Mon Nov 14 15:40:32 2016 +0530

    libglusterfs:Now mempool is added to ctx pool list under a lock
    
    mempool is added to ctx pool list without any lock. This can cause undefined
    behaviour in case of multithreaded environment.
    
    Fix: modify the list only under ctx->lock
    
    > Reviewed-on: http://review.gluster.org/15842
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    > Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    > Reviewed-by: Poornima G <pgurusid@redhat.com>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    (cherry picked from commit 277008a3a8583ef10cec9e4182960792e56c5c10)
    
    Change-Id: I7bdbb3db48a899bb0e41427e149b13c0facaedba
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    BUG: 1397664
    Reviewed-on: http://review.gluster.org/15908
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>

Comment 3 Kaushal 2017-03-08 10:19:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.1, please open a new bug report.

glusterfs-3.9.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-January/029725.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.