Bug 1405937 - Refresh failed when adding an OSE provider
Summary: Refresh failed when adding an OSE provider
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Ari Zellner
QA Contact: Einat Pacifici
URL:
Whiteboard: container:ems_refresh
: 1410417 1410934 1413049 (view as bug list)
Depends On:
Blocks: 1412312
TreeView+ depends on / blocked
 
Reported: 2016-12-19 08:57 UTC by Jan Krocil
Modified: 2020-06-11 13:09 UTC (History)
21 users (show)

Fixed In Version: 5.8.0.0
Doc Type: Known Issue
Doc Text:
When OpenShift Container Platform contains at least one image in any namespace with either the "dockerImageReference" or "dockerImageManifest" field missing, Red Hat CloudForms fails to refresh the entire inventory, and the last refresh shows "Error - Less Than A Minute Ago no implicit conversion of nil into”. Please contact support for a solution.
Clone Of:
: 1412312 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:14:53 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:
epacific: automate_bug+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1410374 0 unspecified CLOSED Unable to perform inventory refresh in CFME 57017 with OCP as a provider 2021-02-22 00:41:40 UTC

Internal Links: 1410374

Comment 2 Federico Simoncelli 2016-12-19 16:15:39 UTC
Ari can you take a look at this?

Comment 3 Federico Simoncelli 2016-12-19 16:17:59 UTC
Jan please add the specific CFME version you used.

Comment 5 Pavel Zagalsky 2016-12-20 08:50:00 UTC
The specific scenario is happening with a OpenShift 3.3 provider that has this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1404561
If needed, I can provide this OSE's details

Comment 6 Ari Zellner 2016-12-20 09:43:56 UTC
Upstream PR: https://github.com/ManageIQ/manageiq/pull/13263

Comment 13 Pavel Zagalsky 2016-12-25 12:57:21 UTC
Looks like it was fixed with Ari's PR. Will change it to Verified once it merged and gets to Downstream

Comment 14 Barak 2017-01-05 13:45:19 UTC
*** Bug 1410417 has been marked as a duplicate of this bug. ***

Comment 17 Federico Simoncelli 2017-01-11 21:57:21 UTC
*** Bug 1410934 has been marked as a duplicate of this bug. ***

Comment 18 Federico Simoncelli 2017-01-12 15:46:19 UTC
*** Bug 1410374 has been marked as a duplicate of this bug. ***

Comment 19 Federico Simoncelli 2017-01-23 10:54:59 UTC
*** Bug 1413049 has been marked as a duplicate of this bug. ***

Comment 20 Andrew Dahms 2017-05-25 00:27:09 UTC
Moving the 'requires_doc_text' to '-'.


Note You need to log in before you can comment on or make changes to this bug.