Bug 1410374 - Unable to perform inventory refresh in CFME 57017 with OCP as a provider
Summary: Unable to perform inventory refresh in CFME 57017 with OCP as a provider
Keywords:
Status: CLOSED DUPLICATE of bug 1414508
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Federico Simoncelli
QA Contact: Einat Pacifici
URL:
Whiteboard: container:ems_refresh
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 10:59 UTC by Archit Sharma
Modified: 2017-01-27 00:29 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 16:16:39 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1405937 0 high CLOSED Refresh failed when adding an OSE provider 2021-02-22 00:41:40 UTC

Internal Links: 1405937

Description Archit Sharma 2017-01-05 10:59:29 UTC
Description of problem:
Connected CFME 57017 to OSE provider. 

Version-Release number of selected component (if applicable):
CFME 5.7.0.17

How reproducible:


Steps to Reproduce:
1. connect CFME 57017 to an OSE provider
2. Turn on C&U. Wait for refresh to happen first
3. Refresh fails to happen

Actual results:

"undefined method `each_with_object' for nil:NilClass" 

..under 'Last Refresh' on ems_container/1 route.

Expected results:

xyz minutes ago. Successful.

Additional info:
Error details in http://pastebin.test.redhat.com/443191

Comment 2 Archit Sharma 2017-01-06 11:21:40 UTC
This looks like it's present in 57017, but works fine in 57013.

So maybe some problem with partial refresh functionality introduced later? (not sure if it was present in 57013 as well? ..but it's evident from logs linked in description)

Comment 3 Federico Simoncelli 2017-01-12 15:46:19 UTC
Archit, this seems a duplicate of bug 1405937.
Please let us know if the fix for bug 1405937 is not working for you. Thanks.

*** This bug has been marked as a duplicate of bug 1405937 ***

Comment 5 Federico Simoncelli 2017-01-23 16:16:39 UTC
Relevant log here reported:

[----] E, [2017-01-04T10:46:19.466302 #60599:fe1140] ERROR -- : MIQ(ManageIQ::Providers::OpenshiftEnterprise::ContainerManager::Refresher#refresh) EMS: [perf-ose], id: [1] Refresh failed
[----] E, [2017-01-04T10:46:19.469542 #60599:fe1140] ERROR -- : [NoMethodError]: undefined method `each_with_object' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2017-01-04T10:46:19.469717 #60599:fe1140] ERROR -- : /var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:168:in `parse_env_variables'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:191:in `parse_openshift_image'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:17:in `block in get_openshift_images'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:136:in `process_collection_item'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:130:in `block in process_collection'
/opt/rh/rh-ruby23/root/usr/share/ruby/delegate.rb:341:in `each'
/opt/rh/rh-ruby23/root/usr/share/ruby/delegate.rb:341:in `block in delegating_block'

Which makes it a duplicate of bug 1414508.

*** This bug has been marked as a duplicate of bug 1414508 ***


Note You need to log in before you can comment on or make changes to this bug.