Bug 14474 - "Test Configuration" locks up for Voodoo3 cards (button is gone, good)
"Test Configuration" locks up for Voodoo3 cards (button is gone, good)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 14076 15084 16995 17365 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-22 17:21 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 00:30:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This following report was forwarded to the XFree86 project. (1.79 KB, text/plain)
2000-08-01 01:53 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2000-07-22 17:21:54 EDT
This issue has been reported in beta2, but I cannot find an existing
bugzilla entry to update, and I want to make sure this doesn't fall through
the cracks.

"Test Configuration", on the X setup screen, hangs if you use a PS-2 mouse.
Comment 1 Matt Wilson 2000-07-25 11:29:34 EDT
If you're using a wheelmouse and selected PS/2 as the protocol, this should be
fixed in beta5.
Comment 2 Sam Varshavchik 2000-07-29 23:47:02 EDT
Installer in pinstripe still locks up on me at this point.  Voodoo 3 video card
with 16MB RAM, 30-66Khz/50-100Hz refresh rates.  PS-2 Kensington mouse with a
scrollwheel.

"Test Configuration", instead of giving me a 1280x1024 display (maximum
resolution in this frequency range), gives me what looks like a 640x480 display
with a 1280x1024 virtual screen.  I reliably reproduce this every time.

Upon exit from the test screen, the anaconda installer display appears
noticeably garbled, and is no longer responsive to mouse input.

If the configuration is not tested, the installer appears to write out a
passable X configuration.

Comment 3 Matt Wilson 2000-07-29 23:54:14 EDT
Same thing happens here, seems to be an X server bug.
Comment 4 Glen Foster 2000-07-30 15:02:23 EDT
I'd *like* to consider this a show-stopper, but it's an XFree86 bug and we won't
be changing the X-server without XFree changing it first (realistically). 
Someone needs to forward this information to the developers at XFree to ensure
they know about it... I'm unaware of the details for doing so -- otherwise I'd
forward it on.

Sam, could you please find out how to send this defect report on to the XFree
developers and make a note in this bugzilla entry when you've done this?  I'd
really apprecaite it!    - Glen
Comment 5 Sam Varshavchik 2000-07-30 15:14:31 EDT
What exactly is the problem here?  I'm not sure what to report to them -- after
the system is installed, the mouse does work just fine.
Comment 6 Matt Wilson 2000-07-30 15:52:30 EDT
If you start an X server, then run yet another X server on a different screen
(:2), your first X server gets broken and stops responding.
Comment 7 Sam Varshavchik 2000-08-01 01:53:54 EDT
Created attachment 1736 [details]
This following report was forwarded to the XFree86 project.
Comment 8 Michael Fulbright 2000-08-17 16:26:53 EDT
*** Bug 15084 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2000-08-17 16:27:05 EDT
*** Bug 15084 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2000-08-17 16:28:12 EDT
clearing 'Mouse' status; this is a voodoo3 problem, not
a mouse problem.
Comment 11 Michael Fulbright 2000-08-17 16:34:43 EDT
*** Bug 14076 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2000-08-29 12:17:09 EDT
*** Bug 16995 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2000-09-11 11:58:43 EDT
*** Bug 17365 has been marked as a duplicate of this bug. ***
Comment 14 Glen Foster 2001-01-11 16:12:32 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 15 Matt Wilson 2001-01-11 16:18:02 EST
X server problem.
Comment 16 Mike A. Harris 2001-01-18 20:59:13 EST
This bug appears very much to be a Voodoo 3 problem, which will
have to wait until someone that knows about the problem at a deeper level
can provide more intimate details, and perhaps a patch or suggest
a workaround.

Right now, the workaround seems to be "don't test X on Voodoo installs.
Comment 17 Glen Foster 2001-01-30 15:49:21 EST
This defect is now considered MUST-FIX for Florence Release-Candidate #1
Comment 18 Chris Adams 2001-02-09 23:15:00 EST
In fisher, the test button is not there (at least with a Voodoo3 3000 AGP
card).  However, the top of the help at the left says to "Click _Test Setting_".

If there is some logic that decides not to show the button, then maybe it should
also not show that part of the help.

I was looking for this to test, and was momentarily confused. :-)
Comment 19 Mike A. Harris 2001-02-11 11:44:55 EST
I still haven't tracked down any fixes for the Voodoo cards.  Also I haven't
received the test hardware to replicate any of the problems with either.

Thus this is unlikely to be fixed for RC-1.  As such, I'm elevating the
priority.
Comment 20 Chris Evans 2001-02-11 19:38:55 EST
I also don't see the TEST X button in the BETA3 install.
This is good - it always locked my machine, PCI
Voodoo3 2000.

I'm glad the bug is still open, though, as removing the
button is fixing the symptom rather than the cause. I'm
glad people are searching for the cause still (I would have
logged a new bug if this bug were closed ;-)
Comment 21 Mike A. Harris 2001-02-11 23:32:36 EST
This might be related to a problem with the installer being memory
hungry, and trying to start up 2 xservers on memory starved machines.
I'm investigating...
Comment 22 Mike A. Harris 2001-02-27 18:47:54 EST
It is unknown why this problem occurs but it might have to do with the
GUI installer running 2 X servers simultaneously.  Does it work ok if you
install Fisher (not Wolverine) using the text install?  Please test this.

If it does work using the 'test' button in text install on fisher, then it
is a problem with running 2 Xservers, or with using XFree 4 and FBdev
together perhaps.

At this point, I'm inclined to close this bug as it is no longer an issue
regardless of wether it is a symptom fix or not.  As long as the driver
*works* is what is important.

Please let me know the results of text install of fisher.
Comment 23 Sam Varshavchik 2001-02-27 18:59:09 EST
I'll look into it later this week, but I don't think I recall a "test
configuration" button in text mode install...
Comment 24 Sam Varshavchik 2001-03-02 21:10:38 EST
I do not have an update, unfortunately, due to other "problems" :-)

I'll look into it later, and reopen this bug, if so needed.
Comment 25 Mike A. Harris 2001-05-20 18:36:29 EDT
This is not reproduceable in Rawhide for all I can tell.

Note You need to log in before you can comment on or make changes to this bug.