Bug 1410369 - Dict_t leak in dht_migration_complete_check_task and dht_rebalance_inprogress_task
Summary: Dict_t leak in dht_migration_complete_check_task and dht_rebalance_inprogres...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1409186 1462066 1462537
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 10:44 UTC by Nithya Balachandran
Modified: 2017-06-18 15:55 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1409186
Environment:
Last Closed: 2017-01-16 12:27:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2017-01-05 10:44:28 UTC
+++ This bug was initially created as a clone of Bug #1409186 +++

Description of problem:
Code reading reveals a dictionary leak in both the dht_migration_complete_check_task and  dht_rebalance_inprogress_task functions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-12-30 00:07:15 EST ---

REVIEW: http://review.gluster.org/16308 (cluster/dht: Fix dict_leak in migration check tasks) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-02 10:30:14 EST ---

COMMIT: http://review.gluster.org/16308 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 11b6a2c9fc5232b58774cab29873406c0fbfef19
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Dec 30 10:33:13 2016 +0530

    cluster/dht: Fix dict_leak in migration check tasks
    
    Fixed a memleak where dict was not being unrefed
    in the dht_migration_complete_check_task and
    dht_rebalance_inprogress_task functions.
    
    Change-Id: I3d42e9a2e5c8596c985bf6431a68fd3905227383
    BUG: 1409186
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/16308
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 1 Worker Ant 2017-01-05 10:54:38 UTC
REVIEW: http://review.gluster.org/16331 (cluster/dht: Fix dict_leak in migration check tasks) posted (#1) for review on release-3.8 by N Balachandran (nbalacha@redhat.com)

Comment 2 Worker Ant 2017-01-08 10:53:53 UTC
COMMIT: http://review.gluster.org/16331 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 8e67e8a74a9a64844cc7ffc0528771fca3321965
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Dec 30 10:33:13 2016 +0530

    cluster/dht: Fix dict_leak in migration check tasks
    
    Fixed a memleak where dict was not being unrefed
    in the dht_migration_complete_check_task and
    dht_rebalance_inprogress_task functions.
    
    BUG: 1410369
    > Change-Id: I3d42e9a2e5c8596c985bf6431a68fd3905227383
    > BUG: 1409186
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/16308
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    > (cherry picked from commit 11b6a2c9fc5232b58774cab29873406c0fbfef19)
    
    Change-Id: I4e92e4c87b52f6f5ffb859005aa3d525225b4bda
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/16331
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2017-01-16 12:27:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.8, please open a new bug report.

glusterfs-3.8.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-January/000064.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.